Download it now!
Bug 119981 - DOCX FILESAVE Chart Border Style created and modified with Writer disappears
Summary: DOCX FILESAVE Chart Border Style created and modified with Writer disappears
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2018-09-19 14:52 UTC by Gabor Kelemen
Modified: 2019-09-09 10:05 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file with custom border style (15.49 KB, application/vnd.oasis.opendocument.text)
2018-09-19 14:57 UTC, Gabor Kelemen
Details
Screenshot of the file in odt and docx in LO (229.28 KB, image/png)
2018-09-19 14:58 UTC, Gabor Kelemen
Details
The document in LO and Word (252.24 KB, image/png)
2018-09-19 15:02 UTC, Gabor Kelemen
Details
The correct example file from LO (14.76 KB, application/vnd.oasis.opendocument.text)
2018-10-15 13:03 UTC, Gabor Kelemen
Details
Screenshot of the document in docx and odt in current master (86.07 KB, image/png)
2018-11-30 13:19 UTC, Gabor Kelemen
Details
ultrafine dash ooxml before and after export (77.35 KB, image/png)
2019-01-22 12:01 UTC, Adam Kovacs
Details
Example compared LO-odt MSO-docx LO-docx (133.89 KB, image/png)
2019-08-28 14:56 UTC, Timur
Details
Example compared LO-odt MSO-docx LO-docx FIXED (133.89 KB, image/png)
2019-09-09 10:04 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-09-19 14:52:59 UTC
Chart Border Style in DOCX documents created and modified with LibreOffice Writer 6.2.0.0.alpha0+ disappears when the document is opened in LibreOffice Writer 6.2.0.0.alpha0+.
This is side effect of the fixes for bug #108064 - previously the line style was not saved at all. Now it is, but there is no correct mapping between the default LO and MSO styles.

Steps to reproduce:

    1. Open the attached document in Writer.
    2. Change the Style of Chart Border to Fine Dotted
    3. Save the file as DOCX
    4. Reload the file
    5. Open the original file in LibreOffice Writer 
    6. Compare the original and the created file opened in Writer

Actual results:
On the Data Series Window Border Style disappears when the document is opened in LibreOffice Writer 6.2.0.0.alpha0+.
Expected results:
Chart Border should have the same style as the original file when the document is opened in LibreOffice Writer 6.2.0.0.alpha0+.

LibreOffice details:
Version: 6.2.0.0.alpha0+
Build ID: e2a525b00c9ea15408fb64dcb6749405739f58ab
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-18_03:37:59
Locale: hu-HU (hu_HU); Calc: threaded
Comment 1 Gabor Kelemen 2018-09-19 14:57:18 UTC Comment hidden (obsolete)
Comment 2 Gabor Kelemen 2018-09-19 14:58:12 UTC
Created attachment 145016 [details]
Screenshot of the file in odt and docx in LO
Comment 3 Gabor Kelemen 2018-09-19 15:02:15 UTC
Created attachment 145017 [details]
The document in LO and Word
Comment 4 Timur 2018-10-11 14:29:27 UTC
Still unconfirmed. 
I'll confirm although I'm not sure whether this relates to going further current Adam's export/1-way conversion to also import/2-way conversion.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d5cc52fec12e3c8d1c3561f172d3e1c5434290b3
tdf#108064 OOXML export: keep preset dashes with mso preset linewidths

http://cgit.freedesktop.org/libreoffice/core/commit/?id=47c3b0390e5ad5a894488c47f014cdd7ecba7d2e
tdf#108064 OOXML export: convert LO preset dashes to equivalent MSO presets
Comment 5 Xisco Faulí 2018-10-15 12:44:56 UTC Comment hidden (obsolete)
Comment 6 Gabor Kelemen 2018-10-15 13:03:12 UTC
Created attachment 145725 [details]
The correct example file from LO

Sorry, misclicked on upload :)
Comment 7 Adam Kovacs 2018-10-15 14:30:32 UTC Comment hidden (obsolete)
Comment 8 Adam Kovacs 2018-10-15 14:31:04 UTC
There was a fix about this in this commit:
https://gerrit.libreoffice.org/#/c/61417/
For some more details, see the comments here:
https://bugs.documentfoundation.org/show_bug.cgi?id=108064
Comment 9 Gabor Kelemen 2018-11-30 13:19:53 UTC
Created attachment 147176 [details]
Screenshot of the document in docx and odt in current master

There was a lot of improvement here, but the style is still not read back correctly from docx.
Comment 10 Adam Kovacs 2019-01-22 12:01:47 UTC
Created attachment 148510 [details]
ultrafine dash ooxml before and after export

Different result here.
Comment 11 Xisco Faulí 2019-06-26 09:41:13 UTC
Dear Adam Kovacs,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 12 Timur 2019-08-28 14:56:47 UTC
Created attachment 153713 [details]
Example compared LO-odt MSO-docx LO-docx

Screenshots here don't correspond fully to example document because width is changed. 
Here is a screenshot of example file  LO-odt MSO-docx LO-docx, with the original width.
Comment 13 Regina Henschel 2019-09-07 20:19:49 UTC
Fixed with commit https://cgit.freedesktop.org/libreoffice/core/commit/?id=57c9bdab377a00649299d1a4c9ed2f9e5e03b84e

Fix is available in Version: 6.4.0.0.alpha0+ (x64)
Build ID: 61b757f31f25cda6d595f64226181c7a82ce8d7f
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-07_17:48:35
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 14 Timur 2019-09-09 10:04:36 UTC
Created attachment 154050 [details]
Example compared LO-odt MSO-docx LO-docx FIXED

Yes, looks good.