Bug 120281 - Navigator loses multi-selection one second after right-clicking on it (Win-only)
Summary: Navigator loses multi-selection one second after right-clicking on it (Win-only)
Status: RESOLVED DUPLICATE of bug 128285
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2018-10-03 09:22 UTC by Thomas Lendo
Modified: 2019-10-29 08:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2018-10-03 09:22:35 UTC
The Navigator loses multi-selection of node items one second after right-clicking on the selection. For me, there's nothing in the context menu that shouldn't be usable through multi-selection and that justifies the disappearing of the multi-selection.

Steps to reproduce:
1. Open or create a Writer document with several headings.
2. Open Navigator (F5) or go to the Navigator pane in the Sidebar.
3. Make sure that a heading is selected in the Navigator and not a table, hyperlink, etc.
4. Open the 'Content Navigation View' with the button at the bottom and left-most position in the Navigator button area.
5. Select multiple headings with ctrl + mouse clicks or shift + mouse clicks.
6. Right-click at one of the selected headings (not at another not-selected heading).

Actual result:
After about a second, the multi-selection disappears and only the heading is selected where the cursor is in the document.

Expected result:
The multi-selection doesn't disappear.
Comment 1 Thomas Lendo 2018-10-03 09:23:52 UTC
Tested with Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 8; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-AT (de_AT); Calc: group

and Version: 6.2.0.0.alpha0+ (x64)
Build ID: 89a60912bba7ffd6f65ea99f4664f343c5025c95
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-01_03:18:33
Locale: de-AT (de_AT); Calc: CL
Comment 2 Buovjaga 2018-10-22 18:05:23 UTC
Repro on Win, not on Lin. Tested with attachment 145437 [details]

Multi-selection does not work for me in 6.1.2, but I guess that might be something Jim fixed for 6.2.0.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 9a373521d7a328197a4bf9abeb0a981b7acba896
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
Built on 19 October 2018

Version: 6.2.0.0.alpha1+ (x64)
Build ID: 8274c4c62df5b937b3f0bec9e1eeca85f3b219d4
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-22_01:47:50
Locale: fi-FI (fi_FI); Calc: threaded
Comment 3 QA Administrators 2019-10-23 02:47:50 UTC Comment hidden (obsolete)
Comment 4 Jim Raykowski 2019-10-28 21:32:41 UTC
Hi Thomas and Buovjaga,

Bug 128285 is a duplicate of this bug report with a recently merged patch. I would have filed it under this one but didn't know it existed until just now while searching through recent list of untouched bugs.
Comment 5 Buovjaga 2019-10-29 08:47:39 UTC
Ok, fine, let's dupe this to it :)

*** This bug has been marked as a duplicate of bug 128285 ***