Bug 120374 - VBA button disappears after resaving to XLSM, also doens't work if saved to ODS
Summary: VBA button disappears after resaving to XLSM, also doens't work if saved to ODS
Status: RESOLVED DUPLICATE of bug 117266
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Macro-VBA
  Show dependency treegraph
 
Reported: 2018-10-07 11:05 UTC by Nikolai
Modified: 2021-09-22 10:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File that reproduces the issue (39.75 KB, application/zip)
2018-10-07 11:06 UTC, Nikolai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolai 2018-10-07 11:05:47 UTC
Description:
In an .xlsm document with a macro tied to a button, the button disappears upon saving the document.

Steps to Reproduce:
1. Open attached file. Make sure macros are enabled.
2. Click "Edit document".
3. Edit a cell.
4. Edit -> Edit Mode.
5. You're prompted to save. Click Save.
6. Save as .xlsm.

Actual Results:
Green button disappears.

Expected Results:
Green button should remain and work as before.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Nikolai 2018-10-07 11:06:28 UTC
Created attachment 145441 [details]
File that reproduces the issue
Comment 2 MM 2018-10-07 23:07:40 UTC
Confirmed on windows 7 x64 with Version: 6.0.7.1 (x64)
Build ID: 5d2cb2a5dd04fe174b336488731eb50bbb5faed3
CPU threads: 3; OS: Windows 6.1; UI render: default

and ubuntu 16.04 x64 with Version: 5.1.6.2
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: single

Saving as xlsm and xlsx loses the button. Saving as xls is fine, only the button is grey instead of green.
Comment 3 QA Administrators 2019-10-08 02:28:42 UTC Comment hidden (obsolete)
Comment 4 Nikolai 2019-10-08 09:25:28 UTC
The bug is still present.

Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded
Comment 5 Timur 2021-09-22 10:58:41 UTC
Repro 7.3+.
Let's consider a duplicate so far.

*** This bug has been marked as a duplicate of bug 117266 ***