Bug Hunting Session
Bug 120392 - Unclear PDF, ePUB button name in Customize dialog
Summary: Unclear PDF, ePUB button name in Customize dialog
Status: RESOLVED DUPLICATE of bug 108458
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-07 22:32 UTC by Edmund Laugasson
Modified: 2018-10-31 23:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
current master / 6.2.0 Export As menu entries (24.52 KB, image/png)
2018-10-08 14:16 UTC, V Stuart Foote
Details
EPUB choices, no difference (12.08 KB, image/png)
2018-10-08 18:00 UTC, Edmund Laugasson
Details
PDF choices, no difference (14.99 KB, image/png)
2018-10-08 18:01 UTC, Edmund Laugasson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Edmund Laugasson 2018-10-07 22:32:29 UTC
Description:
When trying to add the PDF, ePUB button to toolbar that gives a dialog box before exporting then both buttons in settings have same name and that is misleading. Currently only experimenting gives the answer which button does what and it takes too much time and is very bothering.

Steps to Reproduce:
1. View->Toolbars->Customize
2. choose Standard toolbar which is chosen by default
3. open category "Documents"
4. scroll a bit down and there are two buttons with same name in both cases: either PDF or EPUB

Actual Results:
Impossible to distinguish between buttons: direct action or settings+action. It violates the default policy where 3 dots in name mean the dialog window with optin to change settings and also cancel the activity.

Expected Results:
Possible to understand which button does what. Expectations are explained in "Additional information" section together with additional explanation.


Reproducible: Always


User Profile Reset: No



Additional Info:
E.g. in case of printing there are buttons "Print" and "Print Directly" - obviously the last one does it directly but first one gives an option to change settings before printing. In fact would expect here also the 3 dots as it is a common tradition to have 3 dots with choices that allow settings and do not act immediately like choices without 3 dots. Hopefully can you fix that as well (Print -> Print...) - will not file a new bug in case of print button.

Would expect the following names:
- PDF...  (callout text: Export to PDF...)
- PDF directly (callout text: Export to PDF directly)
------------------------
- EPUB... (callout text: Export to EPUB...)
- EPUB directly (callout text: Export to EPUB directly)

Resetting user profile does not help here.
This applies to all LibreOffice modules in all platforms where is possible to export to PDF, EPUB. Did not check but there might be similar identities in button names.
Comment 1 V Stuart Foote 2018-10-08 14:14:50 UTC
Essentially the issues of bug 117528 but that is set dupe of the general case.

Other "Additional info" here looks to already be implemented with the ellipsis from the "Export As" menu in current master/6.2.0
Version: 6.2.0.0.alpha0+ (x64)
Build ID: e7d5bad5ae083da12c3ec4a4a8bdc8b42447a242
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-06_02:55:02
Locale: en-US (en_US); Calc: threaded

*** This bug has been marked as a duplicate of bug 108458 ***
Comment 2 V Stuart Foote 2018-10-08 14:16:55 UTC
Created attachment 145472 [details]
current master / 6.2.0 Export As menu entries

clip of current menu Export As with ellipsis used on entries opening dialogs.
Comment 3 Edmund Laugasson 2018-10-08 17:57:00 UTC
Sounds nice - waiting 6.2.x...
Comment 4 Edmund Laugasson 2018-10-08 18:00:25 UTC
Created attachment 145489 [details]
EPUB choices, no difference

To be precise, I made screenshots of the toolbar customization dialog - expecting also there to see difference, which currently does not exist.
Comment 5 Edmund Laugasson 2018-10-08 18:01:13 UTC
Created attachment 145490 [details]
PDF choices, no difference

To be precise, I made screenshots of the toolbar customization dialog - expecting also there to see difference, which currently does not exist.
Comment 6 V Stuart Foote 2018-10-08 19:53:22 UTC
(In reply to Edmund Laugasson from comment #4)
> Created attachment 145489 [details]
> EPUB choices, no difference
> 
> To be precise, I made screenshots of the toolbar customization dialog -
> expecting also there to see difference, which currently does not exist.

Yes that is correct. The issue is the labeling passed for use in the Customization dialog. The EPub and PDF labels are generic.

The commands are:

.uno:ExportToEPUB (which opens the dialog and receives the ellipsis);
.uno:ExportDirectlyToEPUB (which directly exports to EPUB with defaults).

Similar pair of UNO controls for the Export to PDF .uno:ExportToPDF and .uno:ExportDirectToPDF

=-ref-=

https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/GenericCommands.xcu#4977