Bug Hunting Session
Bug 120513 - LibreOffice Calc warning message when opening an XLSX file is misleading
Summary: LibreOffice Calc warning message when opening an XLSX file is misleading
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: low minor
Assignee: Roman Kuznetsov
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks: Error-Messages
  Show dependency treegraph
 
Reported: 2018-10-11 12:36 UTC by NISZ LibreOffice Team
Modified: 2018-12-18 10:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
A screenshot showcasing the issue. (8.96 KB, image/png)
2018-10-11 12:36 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-10-11 12:36:06 UTC
Description:
LibreOffice Calc offers the following options for reculation of XLSX files on file load:
    • Always recalculate
    • Never recalculate
    • Prompt user

If we set it to Prompt user, a dialog appears every time an XLSX file is opened with the following message:
This document was last saved by Excel. Some formula cells may produce different results when recalculated. Do you want to recalculate all formula cells now?

This message is misleading as it is displayed every time an XLSX file is opened even when the file was created by and saved only with LibreOffice Calc. The wording should be therefore something like that:
This document was saved in Excel 2007-2019 format (.xlsx). Some formula cells may produce different results when recalculated. Do you want to recalculate all formula cells now?

Steps to Reproduce:
1. Go to Tools > Options > LibreOffice Calc > Formula and select “Prompt user” for “Excel 2007 and newer” under Recalculation on File Load.
2. Create a simple spreadsheet and save it as XLSX.
3. Reload the file by clicking on File > Reload.

Actual Results:
The following message appears:
This document was last saved by Excel. Some formula cells may produce different results when recalculated. Do you want to recalculate all formula cells now?

Expected Results:
The message shouldn't say that the document was saved by Excel just because it has XLSX extension. The message should be something like that:
This document was saved in Excel 2007-2019 format (.xlsx). Some formula cells may produce different results when recalculated. Do you want to recalculate all formula cells now?


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-10-11 12:36:40 UTC
Created attachment 145605 [details]
A screenshot showcasing the issue.
Comment 2 Adolfo Jayme 2018-10-13 05:57:52 UTC
Thanks for filing. → NEW
Comment 3 Xisco Faulí 2018-10-15 12:19:48 UTC
The sentence is here: https://opengrok.libreoffice.org/xref/core/sc/inc/globstr.hrc#471
Comment 4 Andras Timar 2018-10-27 08:36:16 UTC
Did you check that the message depends on the file format and not on the generator of the file?
Comment 5 Gabor Kelemen 2018-10-27 17:11:00 UTC
(In reply to Andras Timar from comment #4)
> Did you check that the message depends on the file format and not on the
> generator of the file?

We definitely reproduced it with a LO-made xlsx.
Comment 6 sophie 2018-10-30 10:37:20 UTC
Thanks for reporting the bug. I'm not sure it's needed to add the version of the file format, so we don't need to change it (and maybe forget :-) in the future, I propose:
--------------------------
This document was saved in Excel file format (.xlsx). Some formula cells may produce different results when recalculated. Do you want to recalculate all formula cells now?
--------------------------
Comment 7 Commit Notification 2018-12-18 08:54:02 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1cc7cc6234354fd5c09620374d5ec1a86709fb26%5E%21

tdf#120513 Change error message for Excel files about recalculate

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.