Download it now!
Bug 120553 - LibreOffice Draw crashes on setting bg pic and then replacing it with other option.
Summary: LibreOffice Draw crashes on setting bg pic and then replacing it with other o...
Status: RESOLVED DUPLICATE of bug 120069
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.1.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-12 17:38 UTC by jovial7joe
Modified: 2018-10-14 14:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["NameOrIndex::NameOrIndex(unsigned short, rtl::OUString const&)"]


Attachments
Screenshot after recovary of document. (868.14 KB, image/png)
2018-10-12 17:42 UTC, jovial7joe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jovial7joe 2018-10-12 17:38:30 UTC
Description:
It crashes, when I set background picture (bitmap) then select anything else from the drop-down list of background in the right pane, tabbed as 'Page'.
Fortunately, recovers the file.

Steps to Reproduce:
1. Set a background picture.
2. Select another option from "background" on the right pane "Page"
3. It crashes

Actual Results:
LibreOffice Crashes and goes to document recovery, after recovery there is an unwonted box under "backgrounds".

http://crashreport.libreoffice.org/stats/crash_details/66c17efa-a981-4993-8117-5deb9bea887e

Expected Results:
Picture must fade and be replaced by the selected option.

Enhancement Tip: Please provide tweaks for such images on the same pane.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.1.2
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
CPU threads: 2; OS: Linux 4.9; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 1 jovial7joe 2018-10-12 17:42:32 UTC
Created attachment 145660 [details]
Screenshot after recovary of document.
Comment 2 Julien Nabet 2018-10-13 13:35:25 UTC
On pc Debian x86-64 with LO Debian package 6.1.2.1, I could reproduce this but I don't reproduce this with master sources updated today.

Perhaps it's already fixed on pre release 6.1.3.

Xisco: thought it could be a dup of tdf#120069
Comment 3 Xisco Faulí 2018-10-14 14:45:06 UTC
Yes, this is a dupe of bug 120069 and it will be fixed in LibreOffice 6.1.3.2

*** This bug has been marked as a duplicate of bug 120069 ***