Bug 120069 - Crash in: libmergedlo.so attempting to set a page background to 'Color' from 'None'
Summary: Crash in: libmergedlo.so attempting to set a page background to 'Color' from ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: highest critical
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.2.0 target:6.1.3
Keywords: bibisected, bisected, haveBacktrace, regression
: 120183 120553 120934 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-22 19:23 UTC by Drew Jensen
Modified: 2018-10-26 10:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["XFillColorItem::XFillColorItem(rtl::OUString const &,Color const &)","SfxStringItem::SfxStringItem(unsigned short,rtl::OUString const &)"]


Attachments
draw file (463.51 KB, application/vnd.oasis.opendocument.graphics)
2018-09-22 19:23 UTC, Drew Jensen
Details
crash error - print screen (25.92 KB, image/png)
2018-09-22 19:27 UTC, BogdanB
Details
BT without symbols (5.03 KB, text/plain)
2018-09-22 19:47 UTC, Telesto
Details
gdb backtrace (29.76 KB, text/x-log)
2018-09-23 09:15 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2018-09-22 19:23:33 UTC
Created attachment 145118 [details]
draw file

This bug was filed from the crash reporting server and is br-7913b307-769c-4af2-b46b-2a2e4841b4e0.
=========================================

This crash happens consistently running on Ubuntu 18.04 with both version 6.1 and 6.2Alpha.

The crash does not happen using version 6.0.6. 


Steps to reproduce:

1 - open attached Draw file

2 - open the side bar if it is not and go to the properties tab

3 - for the page background attempt to change it from 'None' to 'Color'


Crash
Comment 1 BogdanB 2018-09-22 19:27:52 UTC
Created attachment 145119 [details]
crash error - print screen

Confirm on Linux. LO 6.2. See screenshot.

Version: 6.2.0.0.alpha0+
Build ID: 66232248ff55639052ddb76918d555e21dc9c46b
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-09-20_19:40:04
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 2 Telesto 2018-09-22 19:47:47 UTC
Created attachment 145121 [details]
BT without symbols

Repro
Version: 6.2.0.0.alpha0+
Build ID: d5a2202f955657e427670a87c2d4e5638884517b
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-12_02:38:23
Locale: nl-NL (nl_NL); Calc: CL

no repro with
Versie: 6.1.0.2
Build ID: b3972dcf1284967612d5ee04fea9d15bcf0cc106
CPU-threads: 4; Besturingssysteem: Windows 6.3; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 Xisco Faulí 2018-09-23 09:12:33 UTC
oh, it points back to me :-(

author	Xisco Fauli <xiscofauli@libreoffice.org>	2018-07-14 20:37:56 +0200
committer	Xisco Faulí <xiscofauli@libreoffice.org>	2018-07-27 13:09:06 +0200
commit	c57f10b67fceef47d304d74dce93be7389a7720c (patch)
tree	528be49a244a7643fb8e2603ac0159a9b79ead4c
parent	228b9801f1ec440cf3090a6f2ff24722c5bc26d0 (diff)
tdf#111306: Hide background widget in sidebar in master and notes view

bisected with: bibisect-linux64-6.2
Comment 4 Xisco Faulí 2018-09-23 09:15:08 UTC
Created attachment 145126 [details]
gdb backtrace
Comment 5 Xisco Faulí 2018-09-23 09:42:57 UTC
Oh, I disable the master background in Impress but not in Draw, and both components share common code.

Patch in gerrit: https://gerrit.libreoffice.org/#/c/60913/
Comment 7 Commit Notification 2018-09-23 21:00:10 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dd7fd51a053be6e664a1a358501dd27e0118f221&h=libreoffice-6-1

tdf#120069: Do not crash changing background color in draw

It will be available in 6.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-09-24 17:28:08 UTC
Crash signature changes depending on what we choose in the dropdown list.

SfxStringItem::SfxStringItem(unsigned short,rtl::OUString const &) -> 
http://crashreport.libreoffice.org/stats/crash_details/5a64f768-dcf7-4207-bef8-72cb580921d7
Comment 9 Drew Jensen 2018-09-28 14:07:09 UTC
*** Bug 120183 has been marked as a duplicate of this bug. ***
Comment 10 BogdanB 2018-10-01 10:50:00 UTC
Verified on 6.2 alfa. No crash.

Version: 6.2.0.0.alpha0+
Build ID: a906b68a9fff30c2af5c03189e59c1952cd3f69f
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-09-30_19:07:59
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 11 Xisco Faulí 2018-10-14 14:45:06 UTC
*** Bug 120553 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2018-10-26 10:47:18 UTC
*** Bug 120934 has been marked as a duplicate of this bug. ***