Bug 120558 - Calc hangs when pasting data with some empty cells into the whole column (steps in comment 10)
Summary: Calc hangs when pasting data with some empty cells into the whole column (ste...
Status: RESOLVED DUPLICATE of bug 112000
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2 all versions
Hardware: All All
: medium normal
Assignee: Dennis Francis
URL:
Whiteboard:
Keywords: bibisected, perf, regression
Depends on:
Blocks: Paste multi_type_vector-regressions
  Show dependency treegraph
 
Reported: 2018-10-13 04:31 UTC by Charlie Plett
Modified: 2019-05-20 08:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
video showing the bug (11.81 MB, video/mp4)
2018-10-13 11:26 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Charlie Plett 2018-10-13 04:31:23 UTC
Description:
When I paste data into a selected column then Calc crashes.

Steps to Reproduce:
1.Copy some data.
2.Select a column
3.Paste data into column

Actual Results:
Calc stopped doing anything and froze until it crashed.

Expected Results:
Pasted the data into the top of the column.


Reproducible: Always


User Profile Reset: No



Additional Info:
I wonder if Calc is trying to copy the data into every cell up to forever? And then it can't handle the workload.
Comment 1 Oliver Brinzing 2018-10-13 09:15:15 UTC Comment hidden (obsolete)
Comment 2 BogdanB 2018-10-13 11:18:38 UTC
Oliver, please repeat your experiment but now like this:

A1 = AAA
A2 = BBB
A3 = CCC

select A1:A3
ctrl + c
select column B
ctrl + v

column B (B1:B1048576) is filled with data 
AAA
BBB
CCC
AAA
BBB
CCC

And now... on A1 put a "1", on A2 a space and on A3 a space; copy this 3 cells and paste again on column B.
In my case the LO freezed and I have 4 cores and SSD.
Comment 3 BogdanB 2018-10-13 11:19:16 UTC
tested on 
Version: 6.2.0.0.alpha0+
Build ID: 144da6d5079bcd435e6637cb5cf95305f3ec1306
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-10-12_02:13:01
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 4 BogdanB 2018-10-13 11:21:45 UTC
I tested again, if I pasted on a full column B 3 values like AAA, BBB, CCC it is ok. But if I have only one cell empty the problems occur.

I will make a video showing the problem.
Comment 5 BogdanB 2018-10-13 11:26:13 UTC
Created attachment 145672 [details]
video showing the bug

In this video pasting only values no problem. Pasting with space in some cells create 100% working for 1 core....
Comment 6 Oliver Brinzing 2018-10-13 12:08:10 UTC
(In reply to BogdanB from comment #5)
> Pasting with space in some cells create 100% working for 1 core...

A1 = 1
A2 = (space)
A3 = (space)

now confirming freeze, 100% cpu for 1 core and memory goes up to 280 mb.

but after ~1 min the values are pasted and one can work.
for me this looks like a performance issue.
Comment 7 Julien Nabet 2018-10-13 13:13:29 UTC
On pc Debian x86-64 with master sources updated today + enable-dbgutil, the first copy in column B described in comment 2 is quite long (about 40s).
(i5 and 6Go, no SSD)

Eike: thought you might be interested in this one.
Comment 8 m.a.riosv 2018-10-13 13:32:09 UTC Comment hidden (no-value)
Comment 10 Xisco Faulí 2018-10-15 11:59:41 UTC
Steps to reproduce:
1. Open attachment 134839 [details] from bug 109339
2. Copy A2:A7
3. Select Column D
4. Paste
5. Copy A2:A10
6. Select Column D
7. Paste
-> Hang!
Comment 11 Timur 2018-10-15 14:48:26 UTC
No hang for me with steps from Comment 10. Paste takes 20 seconds.
Please see Bug 109339 and https://bugs.documentfoundation.org/show_bug.cgi?id=109339#c15 and https://bugs.documentfoundation.org/show_bug.cgi?id=109339#c19.
Since that one is WFM, this one can ba a duplicate.
Comment 12 Dennis Francis 2019-05-16 00:35:29 UTC
Lesser the source-block size of the paste is, more the time taken to fill the target column, provided the source-block has at least data of 2 different types.
(numeric, string, formula, empty).

For example, one of the simplest worst case situations is as follows :-
Start with a blank sheet and set A1 to 1 and copy A1:A2, select column B and paste. This should take a really long time to finish compared to that for procedure in comment 10.
Comment 13 Luboš Luňák 2019-05-17 12:10:58 UTC
Another testcase: Do as in comment #12, but first also set A2 to 'ABC'. This one is harder to fix than if A2 is an empty cell.
Comment 14 Luboš Luňák 2019-05-20 08:08:03 UTC

*** This bug has been marked as a duplicate of bug 112000 ***