Download it now!
Bug 120592 - LibreOffice cannot run SVG animation
Summary: LibreOffice cannot run SVG animation
Status: RESOLVED DUPLICATE of bug 108620
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2018-10-14 16:58 UTC by Volga
Modified: 2018-10-14 20:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2018-10-14 16:58:47 UTC
Description:
When I insert an animated SVG downloaded from inkscape.org, the image does not works as expected.

Steps to Reproduce:
1. Open https://inkscape.org/en/~IK/%E2%98%85animation-inkscape-koi-carp
2. Save SVG image from there
3. Open LibreOffice Writer, Calc and Impress
4. Drag Koi_carp_2 into document

Actual Results:
After I inserted this image, the image doesn't show a fish, but showing these notice in LibreOffice:
    ✔️ GOOGLE CHROME
    ✔️ OPERA
    ✔️ FIREFOX

❌️ INTERNET EXPLORER (no animation)

Expected Results:
LibreOffice should make fish swimming.


Reproducible: Always


User Profile Reset: No



Additional Info:
版本:6.1.2.1 (x64)
Build ID:65905a128db06ba48db947242809d14d3f9a93fe
CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; 
区域语言:zh-CN (zh_CN); Calc: group threaded
Comment 1 Jean-Baptiste Faure 2018-10-14 19:48:13 UTC
I reproduce with current master. I think this issue must be re-qualified as enhancement request.

Best regards. JBF
Comment 2 m.a.riosv 2018-10-14 20:39:33 UTC

*** This bug has been marked as a duplicate of bug 108620 ***