Bug Hunting Session
Bug 120860 - KDE5: Copy and Paste don't work with text copied from a cell in calc
Summary: KDE5: Copy and Paste don't work with text copied from a cell in calc
Status: VERIFIED DUPLICATE of bug 120625
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-10-24 09:23 UTC by Vera Blagoveschenskaya
Modified: 2019-05-14 09:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
video (10.59 MB, video/ogg)
2018-10-24 09:24 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-10-24 09:23:32 UTC
Description:
Copy and Paste doesn't work between different LO applications

Steps to Reproduce:
1. Open LO Writer, copy some text and paste it to the same document = OK
2. Open LO Calc, copy text from step 1 to new calc document = OK
3. In Calc, copy new text, try to paste it near = OK
4. Go to Writer, try to copy text from Calc = text from step 1 is pasted!

Actual Results:
Copy and Paste don't work between different LO applications (if there is something in buffer already)

See video in the attachment

Expected Results:
Normal Copy and Paste between different LO documents


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for 

Version: 6.2.0.0.alpha1
Build ID: ff46ad24d1d3cbcea45895520483ed1fd4ff488b
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

Version: 6.2.0.0.alpha1
Build ID: ff46ad24d1d3cbcea45895520483ed1fd4ff488b
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

---

DO NOT reproduced for

Version: 6.1.2.1
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: ru-RU (ru_RU.UTF-8); Calc: group threaded

Version: 5.4.7.2
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: ru-RU (ru_RU.UTF-8); Calc: group
Comment 1 Vera Blagoveschenskaya 2018-10-24 09:24:06 UTC
Created attachment 145962 [details]
video
Comment 2 Vera Blagoveschenskaya 2018-10-24 09:24:47 UTC
Also see bug 
https://bugs.documentfoundation.org/show_bug.cgi?id=120624
Comment 3 Vera Blagoveschenskaya 2018-10-24 09:35:58 UTC
(In reply to Vera from comment #0)

> Additional Info:
> Reproduced for 

> 
> Version: 6.2.0.0.alpha1
> Build ID: ff46ad24d1d3cbcea45895520483ed1fd4ff488b
> CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: gtk3; 
> Locale: ru-RU (ru_RU.UTF-8); Calc: threaded


Sorry, I re-checked
Bug is NOT reproduced for libreoffice calling with gtk3

---> KDE5 Bug
Comment 4 Xisco Faulí 2018-10-24 12:09:09 UTC
reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 3846561f79cf9065abd9ca83c9fbfbe7e52e28e2
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
2018-10-21_02:45:54
Locale: en-US (en_US.UTF-8); Calc: threaded

but not in

Version: 6.2.0.0.alpha0+
Build ID: 3846561f79cf9065abd9ca83c9fbfbe7e52e28e2
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
2018-10-21_02:45:54
Locale: en-US (en_US.UTF-8); Calc: threaded
Comment 5 Katarina Behrens (CIB) 2018-12-07 09:55:41 UTC
more or less the same issue

*** This bug has been marked as a duplicate of bug 120625 ***
Comment 6 Vera Blagoveschenskaya 2019-05-14 09:16:37 UTC
Checked by steps from Comment#0 --> Bug is not reproduced.

Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded