Bug 120872 - Shift-F3 capitalization toggle now affects the entire sentence, not just selected text
Summary: Shift-F3 capitalization toggle now affects the entire sentence, not just sele...
Status: RESOLVED DUPLICATE of bug 49033
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, possibleRegression
Depends on:
Blocks: Shortcuts-Accelerators Character
  Show dependency treegraph
 
Reported: 2018-10-24 13:24 UTC by medelste
Modified: 2018-10-25 12:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description medelste 2018-10-24 13:24:28 UTC
Description:
Shift-F3 capitalization toggle is extremely useful when emphasizing selected portions of text and dialogue.  A new version of LibreOffice Writer now de-capitalizes the entire sentence when any portion of it is selected and Shift-F3 is pressed.  This worked much better the old way - if I want the entire sentence capitalized, I can select the entire sentence.
Thanks

Steps to Reproduce:
1.Type a sentence with several capital letters, such as a city or person's name.  Example: David and Bathsheba went to Jerusalem to meet King Solomon.
2. Select a portion of the sentence (King Solomon) and press Shift-F3 multiple times.


Actual Results:
The unselected capital letters in the sentence will also be changed to lower case, even though they were not selected.
Example: David and bathsheba went to jerusalem to meet KING SOLOMON.

Expected Results:
Should only toggle the capitalization of the selected text.
Expected result: David and Bathsheba went to Jerusalem to meet KING SOLOMON.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2018-10-24 20:35:45 UTC
I confirm this with

Version: 6.2.0.0.alpha1+ (x64)
Build ID: 8274c4c62df5b937b3f0bec9e1eeca85f3b219d4
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-22_01:47:50
Locale: en-US (de_DE); Calc: CL

but not with

Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 2 V Stuart Foote 2018-10-24 21:00:39 UTC

*** This bug has been marked as a duplicate of bug 49033 ***
Comment 3 Dieter 2018-10-25 06:24:40 UTC
(In reply to V Stuart Foote from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 49033 ***

Stuart, I don't think that this is a duplicate of bug 49033. How can you explain, that I can't reproduce it with LO 6.0.6.2? I pressed Shift-F3 for at least 30 times and always get the correct result.
Comment 4 V Stuart Foote 2018-10-25 12:44:58 UTC
With current master/6.2.0 build the cycle case rotation of a selection, when passing through the sentence case transliteration, is being still being affected by bug 49033

So yes the cycling of the selection is correct, but it bleeds over to the whole sentence run.


STR from cmnt 6 of duplicate bug 119495 -> dup to 49033

Perform the following steps:
1. Write two sentences as follows:
  This should be title case.
  John Smith and Joe Blow wrote to fred jones.
2. Select the first sentence and press Shift-F3 once or as many times as needed to have every initial letter capitalised, i.e. "This Should Be Title Case."
3. Select "fred jones" and press Shift-F3
The result is that sentence case is applied to the whole sentence, which now reads as "John smith and joe blow wrote to fred jones."  So this has just uncapitalised "Smith", "Joe", and "Blow", and done nothing to "fred jones".
4. Press Shift-F3 three more times and "fred jones" will become "Fred Jones".  
5. Now select "joe blow" and press Shift-F3.  This changes "Fred Jones" back to "fred jones"!  

Without stepping through cases on a different bit of text, there is no way to get the correct capitalisation through using Shift-F3.

*** This bug has been marked as a duplicate of bug 49033 ***