Download it now!
Bug 120882 - kde5: Active toolbar not always correctly shown in "View" -> "User Interface"
Summary: kde5: Active toolbar not always correctly shown in "View" -> "User Interface"
Status: RESOLVED DUPLICATE of bug 121417
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-10-24 18:51 UTC by Michael Weghorn
Modified: 2018-11-28 16:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2018-10-24 18:51:56 UTC
Version: 6.2.0.0.alpha1+
Build ID: 9dc5234d36ebcafca36aece80b6a9b59da287cda
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); Calc: threaded

This is specific to the qt5/kde5 VCL plugins. It works OK when using e.g. the gtk3 VCL plugin.

Steps to reproduce:

0) make sure that "Standard Toolbar" is used (used by default, so e.g. delete user profile if changed manually)

1) start LibreOffice Writer
2) open the "View" -> "User Interface" menu
3) observe that "Standard Toolbar" is selected (a expected)
4) select "Sidebar" instead
5) observe that sidebar is enabled (as expected)
6) open the "View" -> "User Interface" menu again
7) observe that "Sidebar" is selected (a expected)
8) select "Standard Toolbar" instead
9) observe that sidebar is collapsed (as expected)
10) open the "View" -> "User Interface" menu again
11) check what radio button is checked

Result: The radio button for "Sidebar" is still checked.

Expected result: The radio button for "Standard Toolbar" should be active, since that one was selected in step 8.
Comment 1 Michael Weghorn 2018-10-24 19:23:10 UTC
This seems to be somewhat related to the following commit:

commit a77163f0bd21d018da0e195974b42d6d71503592
Author: Katarina Behrens <Katarina.Behrens@cib.de>
Date:   Mon Oct 22 14:30:20 2018 +0200

    tdf#119856: [Re-]activate menu before dispatching command
    
    Menu entry dispatchers may be cleared (after they've been initially
    set) when an extension comes with its own menu entries. Activating
    the entry sets the dispatcher again so that dispatching a command
    can proceed

If I revert this commit, it works as expected.

I just realized that this seems to be a more general issue with the menu item indices. e.g. clicking some items under "View" -> "Toolbar" most of the time either enables/disables another toolbar than selected or crashes LibreOffice. This also goes away when I temporarily revert the above commit.
Comment 2 Vera Blagoveschenskaya 2018-10-25 06:46:47 UTC
Confirmed from my side

Version: 6.2.0.0.alpha1+
Build ID: 25af42bc70e1a0a61d2ea90d7b0ef1ed6000ed69
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-10-23_18:02:41
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded
Comment 3 Michael Weghorn 2018-11-28 16:12:14 UTC
I can no longer reproduce any longer with a current master build. It most probably got fixed along with bug 121417, therefore marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 121417 ***