Download it now!
Bug 121169 - Export to PDF creates not working file links if they contain åäö characters
Summary: Export to PDF creates not working file links if they contain åäö characters
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2018-11-05 07:01 UTC by patriknygren
Modified: 2019-10-14 02:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
odt file with working/ not working links after pdf export (16.36 KB, application/vnd.oasis.opendocument.text)
2018-11-05 07:03 UTC, patriknygren
Details
test case link (106.55 KB, application/x-zip-compressed)
2018-11-05 17:41 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description patriknygren 2018-11-05 07:01:34 UTC
Description:
Links with åäö characters becomes chaanged when exporting to PDF

Steps to Reproduce:
1. In LibreOffice, create link to Länk.odt
2. Export to PDF
3. The created link in PDF document becomes L<e4>nk.odt

Actual Results:
The created link is changed to L<e4>nk.odt in pdf file.

Expected Results:
The link should be Länk.odt in pdf file.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 patriknygren 2018-11-05 07:03:54 UTC
Created attachment 146308 [details]
odt file with working/ not working links after pdf export
Comment 2 Oliver Brinzing 2018-11-05 17:41:23 UTC
Created attachment 146323 [details]
test case link

i can not confirm this with my attached test case. both links will open the 2 *.odt files fram pdf and *.odt file.
Comment 3 Roman Kuznetsov 2018-11-07 17:35:46 UTC
don't repro in

Версия: 6.2.0.0.alpha1+
ID сборки: 7cf6cee97bc05512fae482733ee45f039e9d2160
Потоков ЦП: 4; ОС:Linux 4.18; Отрисовка ИП: по умолчанию; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Локаль: ru-RU (ru_RU.UTF-8); Calc: threaded

please update your LibreOffice to 6.1.3 and try repeat problem
Comment 4 Xisco Faulí 2018-12-10 17:03:04 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 5 QA Administrators 2019-09-13 02:51:02 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2019-10-14 02:28:51 UTC
Dear patriknygren,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp