Bug Hunting Session
Bug 121177 - Please change the "paragraph symbol" of "Traditional Chinese version" to "↵"
Summary: Please change the "paragraph symbol" of "Traditional Chinese version" to "↵"
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog Formatting-Mark
  Show dependency treegraph
 
Reported: 2018-11-05 14:47 UTC by 00
Modified: 2019-04-05 07:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
English version (25.55 KB, image/png)
2018-11-05 14:50 UTC, 00
Details
Traditional Chinese version (157.68 KB, image/png)
2018-11-05 14:53 UTC, 00
Details
Example with 0x21B5 (21.13 KB, image/png)
2019-03-14 10:05 UTC, Heiko Tietze
Details
『↵』=『Enter』The symbol above the button (404.50 KB, image/png)
2019-03-29 07:23 UTC, 00
Details
WPS Chinese version uses ↵ (40.94 KB, image/png)
2019-03-31 08:31 UTC, 00
Details
LibreOffice presses "Shift+Enter", There will be ↵, Change "Enter" to ↵, Is it so difficult? (136.42 KB, image/png)
2019-03-31 10:09 UTC, 00
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 00 2018-11-05 14:47:23 UTC
Description:
"Paragraph symbol" "¶" is a symbol created by the "Western world".
Therefore, the "paragraph symbol" used in the "Western world" is "¶".

However, the "Oriental World" does not have the symbol "¶" at all.
The "paragraph symbol" used in "Oriental World" is "↵".



Current Microsoft Office practices:
◎, English version.
1. Press the "Paragraph Symbol" of "Enter" to "¶".
◎, Traditional Chinese version.
1. Press the "Paragraph Symbol" of "Enter" to "↵".
2. Press "Shift+Enter" and the "line feed symbol" is "↓".

The following is the "Traditional Chinese version" Office 2019 download URL, you can try for 5 days, the file size is 3.2GB.
http://officecdn.microsoft.com/pr/492350f6-3a01-4f97-b9c0-c7c6ddf67d60/media/zh-tw/ProPlus2019Retail.img



Solution:
1. Provide the "paragraph symbol" of "¶" and "↵" for the user to choose.
2. Use the following URL to solve my other article.
Https://bugs.documentfoundation.org/show_bug.cgi?id=121095


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 00 2018-11-05 14:50:47 UTC
Created attachment 146313 [details]
English version
Comment 2 00 2018-11-05 14:53:20 UTC
Created attachment 146315 [details]
Traditional Chinese version
Comment 3 00 2018-11-13 06:52:53 UTC Comment hidden (spam)
Comment 5 Heiko Tietze 2019-03-14 10:05:35 UTC
Created attachment 149958 [details]
Example with 0x21B5

Couple of options are listed in [1] and it looks like this with DOWNWARDS ARROW WITH CORNER LEFTWARDS. The remaining pilcrow can be changed in sw/source/core/text/frmpaint.cxx #548. However, the look and feel depends heavily on the font and the SYMBOL FOR NEWLINE (shows "N/L") is not available at all for me. So I wonder if we really should go this way.
The actual request is about the icon. Similar to the currency symbol it may vary, but then it likely should go along with the actual symbol in the document. Is there any official support / standarization for the idea to not use a pilcrow? 


[1] https://stackoverflow.com/questions/18927672/newline-symbol-unicode-character
Comment 6 Heiko Tietze 2019-03-14 10:18:14 UTC
Another place with the pilrow is Tools > Options > Writer > Formatting Aids. And there is a break symbol that we show today on Shift+Enter. So exchanging the pilcrow against the arrow requires another symbol here too.
Comment 7 Heiko Tietze 2019-03-28 14:23:03 UTC
We discussed the request in the design meeting. The standard is the pilcrow symbol, and we use the downward arrow to show soft breaks. So we would have to change two symbols - and make it customizable, which adds complexity to the program - what is a huge effort with a very low benefit. Out Taiwanese colleague agreed with this decision to resolve as WFM.
Comment 8 00 2019-03-28 15:13:39 UTC
(In reply to Heiko Tietze from comment #7)

meaning is,
Don't change to "↵"?
Comment 9 Franklin Weng 2019-03-28 15:15:15 UTC
(In reply to 和尚蟹 from comment #8)
> (In reply to Heiko Tietze from comment #7)
> 
> meaning is,
> Don't change to "↵"?

No.  It is not a standard behavior even in Traditional Chinese.
Comment 10 Heiko Tietze 2019-03-28 15:31:13 UTC
(In reply to 和尚蟹 from comment #8)
> meaning is,
> Don't change to "↵"?

Yes, while the idea is tempting the UX team recommends to not do it because of the stated arguments. Feel free to reopen the ticket if you insist on the proposal. And you are very welcome if you do the coding yourself.
Comment 11 00 2019-03-28 16:15:45 UTC
(In reply to Heiko Tietze from comment #10)

The issue is, Everyone is used to using "↵".
In this case, Persist in using "↵" users, Will not use LibreOffice.

Please think clearly...

"↵" is really very important, This is a habit problem.
Trust me, Changed "↵", LibreOffice's market share, Will definitely increase.

I also live in Taiwan, You should ask me first...

I won't write Program.



If you can't use ¶, Don't you feel weird?
Comment 12 Franklin Weng 2019-03-28 19:35:53 UTC
(In reply to 和尚蟹 from comment #11)
> (In reply to Heiko Tietze from comment #10)
> 
> The issue is, Everyone is used to using "↵".

No.

> In this case, Persist in using "↵" users, Will not use LibreOffice.
> 
I don't think so.  I've never heard anyone complaining about this.

> Please think clearly...
> 
> "↵" is really very important, This is a habit problem.
> Trust me, Changed "↵", LibreOffice's market share, Will definitely increase.
> 

It's Microsoft way, not the standard.
Comment 13 00 2019-03-29 07:19:57 UTC
(In reply to Franklin Weng from comment #12)

Persist in using "↵" users, Because will not use LibreOffice, So you won't find this problem.

There are so few users of LibreOffice now, So there are very few people complaining...

correct, In "Traditional Chinese", There is no "paragraph symbol" at all, But the "↵" symbol has in accordance with, Not a Microsoft casual decision.

『↵』=『Enter』The symbol above the button

Because "↵" is the standard, So be sure to use "↵".

Think with the "Enter" button, You will find that, In fact, the right way, It should be that the whole world has to be changed to "↵".

Microsoft used to use "↵" all over the world, Later Microsoft should be affected by LibreOffice, So in 2017, Change the English version to "¶".



Taiwan colleagues, It should be a Who 2 translator, Those 2 translators, Just keen on translation, In software development, Not professional enough, If you can, Please call the Thomas 2 translator, To Here Speak.
Comment 14 00 2019-03-29 07:23:53 UTC
Created attachment 150387 [details]
『↵』=『Enter』The symbol above the button
Comment 15 Heiko Tietze 2019-03-29 08:16:50 UTC
(In reply to 和尚蟹 from comment #13)
> Persist in using "↵" users...

Let's ask the users to get more opinions https://twitter.com/liboDesign/status/1111542364923924480
Comment 16 00 2019-03-29 08:53:04 UTC
(In reply to Heiko Tietze from comment #15)

Survey opinion...

After the investigation came out,
『↵』=『Enter』The symbol above the button
this problem, How to deal with?
Comment 17 Franklin Weng 2019-03-29 15:40:49 UTC
(In reply to Heiko Tietze from comment #15)
> (In reply to 和尚蟹 from comment #13)
> > Persist in using "↵" users...
> 
> Let's ask the users to get more opinions
> https://twitter.com/liboDesign/status/1111542364923924480

Since you started this vote, then run it.  However I don't think it makes any sense, no matter what the result will be.
Comment 18 00 2019-03-30 07:26:38 UTC
The correct approach:
1. Use around the world↵.("↵" = "Enter" The symbol above the button)
2. Only the English version uses ¶, Other places use ↵.
3. Let the user customize the symbol, Push the problem to the user.

3 practices, choose one.

Other practices, It must be an error.
Comment 19 V Stuart Foote 2019-03-30 16:01:35 UTC
The typesetters Pilcrow  - ¶ (U+00B6) shape evolved from the Capitulum - ⸿ (U+2E3F). Use of the Downward Arrow with Corner Leftwards - ↵ (U+21B5) symbol marking on the Enter key is a cross over to computer keyboards from electric typewriter marketing.

The Unicode CLDR does not address locale preference for "paragraph markings", nor has it been covered in published Unicode UAX (#24, #29, #38, #50).

Its use in LibreOffice is strictly decorative--what to label the show/hide formatting button, likewise how to "decorate" paragraph ends on VCL canvas when shown.

It could be changed to be more culturally appropriate, but rather than the ↵ (U+21B5) arrow--seems the IDEOGRAPHIC NUMBER ZERO - 〇 might be the more appropriate choice for the CJK locales.

Would require dynamic glyph on the button, and ability to customize from expert configuration or a widget on the Tools -> Options -> Language Settings -> Languages panel.

A lot of work for what is a marginal enhancement.

IMHO => WF
Comment 20 V Stuart Foote 2019-03-30 16:06:29 UTC
(In reply to V Stuart Foote from comment #19)
>  ... --seems the IDEOGRAPHIC NUMBER ZERO - 〇

Sorry, that is the IDEOGRAPHIC NUMBER ZERO - 〇 (U+3007) from the CJK Symbols and Punctuation Unicode block.
Comment 21 Franklin Weng 2019-03-30 16:17:33 UTC
(In reply to V Stuart Foote from comment #20)
> (In reply to V Stuart Foote from comment #19)
> >  ... --seems the IDEOGRAPHIC NUMBER ZERO - 〇
> 
> Sorry, that is the IDEOGRAPHIC NUMBER ZERO - 〇 (U+3007) from the CJK Symbols
> and Punctuation Unicode block.

I don't think if there is anything "culturally appropriate" here.  U+3007 has never been used as "paragraph markings" in any CJK digital documents or editors AFAIK.

The reporter insist using Corner Leftwards - ↵ (U+21B5) because "it is the symbol of Enter" which applies "paragraph markings" -- kinda ridiculous to me.  So I suggest we can stop the discussion and close it as WONTFIX.
Comment 22 00 2019-03-31 08:00:15 UTC
(In reply to V Stuart Foote from comment #19)

You are totally wrong.

"The symbol above the Enter button" is an independent thing. It has nothing to do with anything.
As long as the keyboard releases the "new format", "The symbol above the Enter button", It will change.
↵=“Format” on the keyboard
Because it is "format", So be sure to use it.

When you press the "A" button on the keyboard, "A" will appear on the screen.
When you press the "Enter button" on the keyboard, "↵" will appear on the screen.
Is there a problem?



In the URL below, The Chinese place is wrong, 〇 (U + 3007) is not a "paragraph symbol", The symbol is also wrong.
https://en.wikipedia.org/wiki/Pilcrow

〇 (U + 3007)=. (U +3002) Chinese Period
. (U +3002) Chinese Period =. (U +002E) English Period

Chinese has no paragraph symbol, If you must explain the Chinese paragraph symbol, It is "the beginning of the sentence, the space is 2 characters".
Comment 23 00 2019-03-31 08:22:30 UTC
(In reply to Franklin Weng from comment #21)

I didn't write, Enter=paragraph symbol, You made a mistake.
What I wrote is, Enter= ↵.

In the Western world
Enter= ↵
Paragraph symbol = ¶
So in the Western world, You can use ↵ or ¶.

In the eastern world
Enter= ↵
There is no "paragraph symbol" in the Eastern world.
So in the Eastern world, Only use ↵.

Do you understand, Enter= ↵, It is something that is common all over the world.

Currently in the Eastern world, Only LibreOffice uses ¶, Other Offices use ↵.



Because it must be revised on a large scale, So don’t want to do it, This is the wrong approach.
Comment 24 00 2019-03-31 08:31:20 UTC
Created attachment 150421 [details]
WPS Chinese version uses ↵
Comment 25 00 2019-03-31 10:09:33 UTC
Created attachment 150423 [details]
LibreOffice presses "Shift+Enter", There will be ↵, Change "Enter" to ↵, Is it so difficult?
Comment 26 00 2019-04-01 08:33:38 UTC
In the front place, Write wrong, Microsoft English version, "Should" At the beginning, use "¶".
Comment 27 Heiko Tietze 2019-04-05 07:19:01 UTC
(In reply to Heiko Tietze from comment #15)

> Let's ask the users to get more opinions

70% vote for keeping the pilcrow. On the French Twitter channel [1] we have 40/20 for pilcrow/arrow and 37% for make it optional. This plus all the comments support the decision to not change the pilcrow.

[1] https://twitter.com/LibreOfficeFR/status/1112032070442864640