Bug 121189 - Chart is not shown after saving .odp as .pptx
Summary: Chart is not shown after saving .odp as .pptx
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Dániel Arató (NISZ)
URL:
Whiteboard: target:7.1.0 target:7.0.2
Keywords: difficultyBeginner, easyHack, filter:pptx, skillCpp
Depends on:
Blocks: OOXML-Chart PPTX
  Show dependency treegraph
 
Reported: 2018-11-06 07:36 UTC by Vera Blagoveschenskaya
Modified: 2020-09-02 13:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
original .odp file (113.45 KB, application/vnd.oasis.opendocument.presentation)
2018-11-06 07:39 UTC, Vera Blagoveschenskaya
Details
save as .pptx (115.13 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-11-06 07:39 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-11-06 07:36:51 UTC
Description:
Chart is not shown after saving .odp as .pptx

Steps to Reproduce:
0. Prepare test .odp document with: text, default chart, picture and table (find it in the attachment)
1. Save .odp as .pptx
2. Open .pptx

Actual Results:
Chart is not shown in .pptx
(find .pptx in the attachment)

Expected Results:
Chart is shown correctly


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for

Version: 6.2.0.0.alpha1+
Build ID: 7cf6cee97bc05512fae482733ee45f039e9d2160
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

Reproduced for

Version: 6.2.0.0.alpha1+
Build ID: 7cf6cee97bc05512fae482733ee45f039e9d2160
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded
Comment 1 Vera Blagoveschenskaya 2018-11-06 07:39:18 UTC
Created attachment 146335 [details]
original .odp file
Comment 2 Vera Blagoveschenskaya 2018-11-06 07:39:45 UTC
Created attachment 146336 [details]
save as .pptx
Comment 3 Xisco Faulí 2018-11-06 11:34:13 UTC
Not reproduced it saved to .PPT

Reproduced in

Version: 6.2.0.0.alpha1+
Build ID: b0da1ca2d7a426ff13f39b21362fbcd5c0580c24
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

most likely it has been reported already...
Comment 4 Vera Blagoveschenskaya 2018-11-06 11:37:58 UTC
(In reply to Xisco Faulí from comment #3)
> most likely it has been reported already...

Quite possibly, but I can't find anything similar via quick search by Summary.
Pls set to duplicate if you will find it.
Comment 5 Buovjaga 2019-09-29 18:13:58 UTC
Still repro with file

Version: 6.4.0.0.alpha0+ (x64)
Build ID: d744838991594eebe27acc4c7d9fb4579d654853
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-29_05:12:00
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 6 Regina Henschel 2020-07-01 16:37:46 UTC
The item
{ "com.sun.star.presentation.ChartShape", &ShapeExport::WriteOLE2Shape },
is missing in
 static NameToConvertMapType const shape_converters
in
https://opengrok.libreoffice.org/xref/core/oox/source/export/shapes.cxx


BTW, version "Inherited from OOo" is wrong, because OOo has no pptx export. But I don't know from memory the first LO version with integrated pptx-export.
Comment 7 Buovjaga 2020-07-01 16:41:06 UTC Comment hidden (obsolete)
Comment 8 Timur 2020-07-02 07:17:34 UTC
(In reply to Buovjaga from comment #7)
> (In reply to Regina Henschel from comment #6)
> > 
> > BTW, version "Inherited from OOo" is wrong, because OOo has no pptx export.
> > But I don't know from memory the first LO version with integrated
> > pptx-export.
> 
> Well, more correct would be "inherited from Go-oo", which had the support,
> but I think it's fine.

We mark as LO 3.3. We should put some See Also here.
Comment 9 Commit Notification 2020-08-31 08:13:35 UTC
Daniel Arato (NISZ) committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0c5ac9d1cb39eac838a612092a8934a6ca12326f

tdf#121189 PPTX export: fix missing chart

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2020-09-01 11:24:21 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 828914a94fe93d5b300bda1d23a049ae92c159e1
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Daniel Arató, thanks for fixing this issue!! should it be closed as RESOLVED FIXED ?
Comment 11 Commit Notification 2020-09-01 11:27:18 UTC
Daniel Arato (NISZ) committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/f366b87d71d774c3a6983224903933bb32b43ff0

tdf#121189 PPTX export: fix missing chart

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Dániel Arató (NISZ) 2020-09-01 11:32:39 UTC
(In reply to Xisco Faulí from comment #10)
> Verified in
> 
> Version: 7.1.0.0.alpha0+
> Build ID: 828914a94fe93d5b300bda1d23a049ae92c159e1
> CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
> Locale: en-US (en_US.UTF-8); UI: en-US
> Calc: threaded
> 
> @Daniel Arató, thanks for fixing this issue!! should it be closed as
> RESOLVED FIXED ?

Hi! Apparently the backport has just been merged too, so yes, I believe this ticket can be considered RESOLVED FIXED.