Bug 121239 - LO Calc -> Format -> Text -> there is no checkbox for option Double Underline
Summary: LO Calc -> Format -> Text -> there is no checkbox for option Double Underline
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2018-11-07 11:55 UTC by Vera Blagoveschenskaya
Modified: 2020-11-06 07:50 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screen (134.51 KB, image/png)
2018-11-07 11:56 UTC, Vera Blagoveschenskaya
Details
video showing the bug in the last version (1.62 MB, video/mp4)
2019-11-09 06:25 UTC, BogdanB
Details
This is the right video (1.71 MB, video/mp4)
2019-11-09 06:27 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-11-07 11:55:58 UTC
Description:
LO Calc -> Format -> Text -> there is no checkbox for option Double Underline

Steps to Reproduce:
1. LO Calc -> Format -> Text


Actual Results:
There is no checkbox near Double Underline (see screen).

Also, expected checkboxes for Section from UPPERCASE till tOOGGLE cASE

Expected Results:
Checkboxes


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for 

Version: 6.2.0.0.alpha1+
Build ID: 7cf6cee97bc05512fae482733ee45f039e9d2160
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

Reproduced for 

Version: 6.2.0.0.alpha1+
Build ID: 7cf6cee97bc05512fae482733ee45f039e9d2160
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

---

FYI:
Checkbox for Double Underline is presented in Writer
Comment 1 Vera Blagoveschenskaya 2018-11-07 11:56:14 UTC
Created attachment 146391 [details]
screen
Comment 2 Xisco Faulí 2018-11-07 13:03:52 UTC
I can reproduce it in

Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
2018-11-06_19:01:37
Locale: en-US (en_US.UTF-8); Calc: threaded

but something is wrong here, If I clik on it, then it's displayed, and both underline and double underline are selected. then, it's not possible to deselect it...
Comment 3 Xisco Faulí 2018-11-07 13:11:21 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

and

Versión: 6.1.2.1
Id. de compilación: 65905a128db06ba48db947242809d14d3f9a93fe
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded
Comment 4 Xavier Van Wijmeersch 2018-11-07 17:33:35 UTC
no repro with

Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-06_19:01:37
Locale: nl-BE (en_US.UTF-8); Calc: threaded

Version: 6.1.4.0.0+
Build ID: b77f4f69bb2f1d3ab740446799da2fd3db9094da
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded

but I can reproduce with

Version: 6.2.0.0.alpha1+
Build ID: 163dd5df9f080a141e201a32c40ff80e1a5d2e34
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); Calc: threaded
Comment 5 BogdanB 2018-11-07 20:38:39 UTC
I tried this steps:
- new calc file
- Format - Text - Double Underline (the checkbox dont't exist)
- enter some text in a cell and again - Format - Text - Double Underline (the checkbox dont't exist)
- now move to another cell and enter some text: - Format - Text - Double Underline (the checkbox is checked inspite I didn't checked Double Underline for that cell)
Comment 6 Dave Barton 2018-11-07 21:01:59 UTC
Cannot reproduce under Windows 7 & 10 with either:
Version: 6.2.0.0.alpha1 (x64)
Build ID: ff46ad24d1d3cbcea45895520483ed1fd4ff488b
CPU threads: 8; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: en-IE (en_GB); Calc: CL
or
Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 8; OS: Windows 6.1; UI render: GL; 
Locale: en-IE (en_GB); Calc: group threaded
I don't understand what checkbox is being referred to, but both the Format Cell dialog and Format > Text menu work for me.
Comment 7 Heiko Tietze 2018-11-08 08:25:53 UTC
No checkbox when off, checkbox visible after click, and (!) it remains shown and checked when switched off- also on other cells.

Version: 6.1.2.1
Build ID: 6.1.2-4
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: de-DE (en_US.UTF-8); Calc: group threaded

Version: 6.2.0.0.alpha1+
Build ID: 13c247b7fee91b0ffb256e85bcd0cf416b3cd83e
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3;
and CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: threaded

Underline is toggled on with Double Underline and unset after switching off. So I suspect the mixture of both option to be the cause of the issue. See also bug 114010.


Ordinary bug, removing UX.
Comment 8 QA Administrators 2019-11-09 03:53:38 UTC Comment hidden (obsolete)
Comment 9 BogdanB 2019-11-09 06:25:19 UTC
Created attachment 155649 [details]
video showing the bug in the last version

Version: 6.3.3.2
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

I have made a screencast of the bug.

I have made 2 tests in this video:
- case 1: nothing double underline but the checkbox is not active to be checked.

- case 2: after applying double underline to the letter A, and moving to the letters B and C, inspite of text NOT being double underlined the checkbox is like B and C are double underlined.

The video is much easier to understand than this text.
Comment 10 BogdanB 2019-11-09 06:27:29 UTC
Created attachment 155650 [details]
This is the right video
Comment 11 Xisco Faulí 2019-11-09 14:48:08 UTC
@Caolán, I thought you might be interested in this issue...
Comment 12 Caolán McNamara 2019-11-09 20:45:38 UTC
https://gerrit.libreoffice.org/#/c/82360/ should make calc work like writer does for this
Comment 13 Commit Notification 2019-11-09 21:41:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2eb56f0fee54e25c2c194d6801861f18240a37be

tdf#121239 set double underline status to false when not double underlined

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-11-11 19:37:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3a2c69a59542c25e95f0368dc81d552a006fdaeb

Related: tdf#121239 overline missing in draw/impress

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2019-11-12 08:56:05 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9dcb9c3d6ca507c537b529a73aa645d6f69bb414

Related: tdf#121239 super/sub not shown as toggles in calc

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-11-12 09:51:52 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/745122c0446c4cda0acdaf16e058f70509364831

Related: tdf#121239 super/sub not shown as toggles in draw/impress

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2019-11-12 11:26:55 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/431950e1eade91f8587d3ecffa73fd09136e16b6

tdf#121239 give writer, calc and draw/impress the same underline options

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2019-11-12 13:03:16 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/aa7b71aaa49ea2cffe85aa8d68f933588b3d829a

Related: tdf#121239 missing contour toggle in draw/impress

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Caolán McNamara 2019-11-12 13:16:55 UTC
Calc looks good in master now I think.

The UPPERCASE <-> tOGGLE cASE options are not properties that are set on or off, but transliteration that change the actual text so they aren't toggles so those remain unchanged here
Comment 20 Heiko Tietze 2019-11-12 14:11:15 UTC
Have your patches any effect on bug 114010?
Comment 21 Caolán McNamara 2019-11-12 14:29:28 UTC
Here UnderlineDouble and UnderlineSingle in the format->text menus are now separate things and apply Double Underline won't report "Single Underline" as true there. The "Underline" toolbar button continues to report an underline status for any underline applied to the context text
Comment 22 Heiko Tietze 2019-11-13 10:32:45 UTC
(In reply to Caolán McNamara from comment #21)
> Here UnderlineDouble and UnderlineSingle in the format->text menus are now
> separate things and apply Double Underline won't report "Single Underline"
> as true there. The "Underline" toolbar button continues to report an
> underline status for any underline applied to the context text

Hm, shift+Ctrl+U not even jumps to the dispatcher. So it's some other is issue.
Comment 23 Caolán McNamara 2019-11-13 10:41:36 UTC
ctrl+shift+u under gtk/gnome is unicode input, i.e. ctrl+shift+u then type df and return inserts eszett (0x00DF)
Comment 24 Heiko Tietze 2019-11-13 11:09:43 UTC
(In reply to Caolán McNamara from comment #23)
> ctrl+shift+u under gtk/gnome is unicode input, i.e. ctrl+shift+u then type
> df and return inserts eszett (0x00DF)

It deletes the text here with master, VCL=gtk3. Works with stable, kde5.

Would be nice to have consistent shortcuts, ctrl+U and shift+ctrl+U.
Comment 25 Caolán McNamara 2019-11-13 11:33:11 UTC
ctrl+shift+u is not under our control