Bug 121307 - Table Design from Impress should be available in Calc and Writer
Summary: Table Design from Impress should be available in Calc and Writer
Status: RESOLVED DUPLICATE of bug 101802
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Table-Styles Sidebar-Properties-Table-Design Table-AutoFormat
  Show dependency treegraph
 
Reported: 2018-11-09 11:03 UTC by Pedro
Modified: 2018-11-13 09:01 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Table Design in Properties section of Sidebar in Impress (99.02 KB, image/png)
2018-11-09 11:03 UTC, Pedro
Details
Current Table Styles in Writer (52.33 KB, image/png)
2018-11-09 11:03 UTC, Pedro
Details
No table styles in Calc (68.89 KB, image/png)
2018-11-09 11:04 UTC, Pedro
Details
Table styles in Excel 2016 (104.28 KB, image/png)
2018-11-09 11:33 UTC, Pedro
Details
Add Table Design to Calc, rename to Table Styles and move location close to other styles. (528.67 KB, image/png)
2018-11-09 11:35 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2018-11-09 11:03:14 UTC
Created attachment 146489 [details]
Table Design in Properties section of Sidebar in Impress

When inserting a new table in Impress, in both the Sidebar Properties section and the Tabbed bar there is an option for Table Design. 

This option shows several Table Styles and allows an user to configure how those Styles can be configured (stronger color in header row and/or first column and/or final row)

I would like to request if this feature can be made available in Calc and replace the Table Styles section in Writer.

Since Calc is the obvious application to manipulate tables this feature should be available to it. Furthermore, offering table styles independently of cell styles is a feature in other spreadsheet applications such as Excel or WPS Spreadsheets. 

Therefore, this is a feature that is necessary in Calc to try to achieve feature parity with other spreadsheet applications.

This also solves the issue of creating more Table Styles without assuming that the final row is a total row since the user will have the flexibility to define that as already happens in Impress. 

I would like to request that this Table Design feature becomes available both in Calc and Writer and that the command to access it is grouped near to the other Styles buttons in all LO modules.
Comment 1 Pedro 2018-11-09 11:03:43 UTC
Created attachment 146490 [details]
Current Table Styles in Writer
Comment 2 Pedro 2018-11-09 11:04:07 UTC
Created attachment 146491 [details]
No table styles in Calc
Comment 3 Pedro 2018-11-09 11:33:20 UTC
Created attachment 146492 [details]
Table styles in Excel 2016
Comment 4 Pedro 2018-11-09 11:35:52 UTC
Created attachment 146493 [details]
Add Table Design to Calc, rename to Table Styles and move location close to other styles.
Comment 5 Pedro 2018-11-09 11:38:16 UTC
Also by making this Table Design option in Calc and Writer we could remove Autoformat Table Styles from both.
Comment 6 Eike Rathke 2018-11-09 16:07:34 UTC
Just to mention that for Calc there is a GSoC idea since a while, but so far nobody dared to pick it up, https://wiki.documentfoundation.org/Development/GSoC/Ideas#Implement_table_styles
Note that it's way more than non-trivial to implement.
Comment 7 Thomas Lendo 2018-11-10 06:33:30 UTC
In theory, I like the idea of a more visual styling like tables in Impress. But there are technical differences:
- Impress table styling (I don't call it Styles) are completely different to table styles in Writer and to AutoFormat table styling.
- Now it's not possible (as far as I know) to use commands to modify style attributes. If you want to modify a style in the sidebar like it's done in Impress now, Bug 107865 - 'UNO commands to modify style-level character and paragraph properties' must be implemented for table styles.


PS: Please use keywords, etc. carefully and read what they do. I'll remove needsDevEval as we don't ask for an EasyHack.
When adding needsUXEval, please also add libreOffice-Ux-advise@... to CC and maybe Cor's and Stuart's and my e-mail.
Comment 8 Roman Kuznetsov 2018-11-10 13:01:10 UTC
just for info: 
"Format as Table" in Excel (2010 and more new) allows not only select a visual style for range but also:
1. Every that "table" on sheet has its own name you can use in formulas with, for example, SUMIF or VLOOKUP
2. "Table" automatic changes its size if you add row or column
3. In this "table" will be active autofilter by default
4. When you add rows in end of "table" then they automatic get all formulas from previous row
5. When you add columns in "table" and enter a formula in to one cell then all cells in this column will be have this formula automatically
6. If you scroll your "table" down, then headers (from first row of "table") will be show in row with column number (will don't need freeze first row)
7. When you enable Total row for this "table" you can select in Total row some different function (sum, average, count, etc.)
Comment 9 Heiko Tietze 2018-11-13 09:01:42 UTC
Let's keep this together with the previously reported issue. Although it's the underlying code aka style description that differs between Writer, Calc and Impress/Draw as well as access via sidebar.

*** This bug has been marked as a duplicate of bug 101802 ***