Bug 121437 - Tooltip for Color Bar interactions missing
Summary: Tooltip for Color Bar interactions missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: Toolbars-Tooltips
  Show dependency treegraph
 
Reported: 2018-11-15 09:35 UTC by andreas_k
Modified: 2019-07-17 10:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2018-11-15 09:35:00 UTC
In draw you can define the color of Area/Line with left/right mouse click at the color bar, this is a great feature but there is no tooltip or anything that the user know of this features.

the developer told me about that hidden feature.

In the color bar tooltip where you see the color name please add als 

- left mouse area color
- right mouse line color
Comment 1 Heiko Tietze 2018-11-15 09:54:31 UTC
You talk about View > Toolbars > Color Bar? And a tip explaining that left click applies the color to the object's area and a right click to the object's line.

Sounds like bad usability those extended help text has to go into the documentation. Nothing to say about exception, though. But it would also be an advantage to have the color info in the tooltip as implemented recently for bug 108751. 

Since the special "clear color" button could be placed better separately from the actual palette it could go into a line with a static text or a tooltip on the control. Putting together: yes for a tip but no to every single color pit.
Comment 2 andreas_k 2018-11-15 10:02:52 UTC
It's an very cool feature (better than in inkscape) and users should know about it. 

About the "clear color" button I would recommend to move it from first item to last item so the arrangement wasn't destroyed and it's still available. I already search in the codebase but I don't know how to fix it.

I would also move the default location of the colorbar from bottom to the left or right sidebar cause our color plate doesn't fit in two lines like you have now on bottom location.

When move Colorbar toolbar to left/right sidebar the default height has to be defined cause now it's to big.

If someone give me some code pointer I can see what I can do.
Comment 3 Cor Nouws 2019-05-11 09:56:58 UTC
(In reply to andreas_k from comment #0)
> In draw you can define the color of Area/Line with left/right mouse click at
> the color bar, this is a great feature but there is no tooltip or anything
> that the user know of this features.

It is/has been part of the text from the Extended Help tips.
But that is currently broken (bug 120538)

> In the color bar tooltip where you see the color name please add als 
> 
> - left mouse area color
> - right mouse line color
Comment 4 andreas_k 2019-07-16 14:33:47 UTC
how can this bug be fixed.
Comment 5 Commit Notification 2019-07-17 10:54:42 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/bebc2280e43fc381e9085f2a397dad9dd7701fdd%5E%21

Resolves tdf#115087 and tdf#121437 - Improvements to color bar

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.