Bug 121478 - cursor focus remains in comment box, even when find-replace finds text in document body
Summary: cursor focus remains in comment box, even when find-replace finds text in doc...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2018-11-17 14:35 UTC by sdc.blanco
Modified: 2020-09-29 12:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2018-11-17 14:35:08 UTC
Procedure:

1.  Use Text Document, with a comment, and cursor in comment box.
2.  Search on a word that is in the Text body.
3.  Hit ESC (to remove search Dialog Box.

Observed behavior:

Cursor returns to comment box.


Expected behavior:

Cursor remains at the "found word" 
(which is also what normally happens when searching in the text body).
Comment 1 Xisco Faulí 2018-12-18 15:46:05 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 6dc36d343aeacb3d1e14ec0c847937d63f4e68a7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Timur 2018-12-20 17:57:22 UTC
I don't reproduce with Edit-Find but I do with Edit-Find&Replace in step 2. 
Please confirm.
Comment 3 sdc.blanco 2018-12-23 16:24:45 UTC
Clarification/Correction:  As noted in #2, the problem appears with Edit/Find&Replace, not with Edit/Find.  

(My original report was not precise/accurate -- have changed bug title)

Appears in:  Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
Comment 4 Dieter 2018-12-28 17:58:47 UTC
Set to NEW because of comment 2 and comment 3
Comment 5 Xisco Faulí 2019-01-02 14:50:32 UTC
Also reproduced in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 6 sdc.blanco 2020-09-29 12:01:52 UTC
Something changed with 7.1.0.0.alpha0+ 
Cannot reproduce, so will close as WFM.

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 3c6177be2705303044e3de262689d593f3d0f282
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: da-DK (en_DK); UI: en-US
Calc: threaded