Bug 121568 - calc: move cell does not update row sum
Summary: calc: move cell does not update row sum
Status: RESOLVED DUPLICATE of bug 121043
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-11-20 23:41 UTC by satphil
Modified: 2018-11-21 13:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
"Before" state of test case. (9.26 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-11-20 23:42 UTC, satphil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description satphil 2018-11-20 23:41:03 UTC
Description:
See attached test case. Sum two rows: A1 + B1 = C1; A2 + B2 = C2 where B1 is blank. Cut B2 and paste into B1. Result C2 is decremented correctly by old B2 value; but result C1 is NOT incremented by new B1 value. Formula of C1 remains correct =SUM($Sheet1.A1:B1) as is C2's formula but C1 result is wrong. Saving file, close and re-open does not fix incorrect C1 result. Undo undo to return to initial state results in C2 now having incorrect result. Bug occurs whether drag and drop or control-x/control-v used. This is a data integrity issue as the wrong answer is being displayed.

Steps to Reproduce:
1. Sum two rows: A1 + B1 = C1; A2 + B2 = C2 where B1 is blank. 
2. Cut B2 and paste into B1. Result C2 is decremented correctly by old B2 value; but result C1 is NOT incremented by new B1 value. 
3. Formula of C1 remains correct =SUM($Sheet1.A1:B1) as is C2's formula but C1 result is wrong. 
4. Saving file, close and re-open does not fix incorrect C1 result. 
5. Undo undo to return to initial state results in C2 now having incorrect result. 
6. Bug occurs whether drag and drop or control-x/control-v used. 


Actual Results:
C1 not incremented by new B1 value; undo does not return to initial state

Expected Results:
C1 incremented by new B1 value; undo does return to initial state


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced reliably by olivier.tilloy@canonical.com on Ubuntu 16.04 and 19.04 (libreoffice 6.1.3.2).
He can also reproduce the issue with the upstream build of libreoffice (6.1.3.2)
Comment 1 satphil 2018-11-20 23:42:51 UTC
Created attachment 146856 [details]
"Before" state of test case.
Comment 2 Xisco Faulí 2018-11-21 13:45:06 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=5ef856e975d7c0396984d588a43fd1a7c7085c55, which is the same as in bug 121043.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 121043 ***