Download it now!
Bug 121621 - FILEOPEN DOCX Change tracking of the list is incorrect when we hide tracked changes in Writer
Summary: FILEOPEN DOCX Change tracking of the list is incorrect when we hide tracked c...
Status: RESOLVED DUPLICATE of bug 118699
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2018-11-22 14:52 UTC by Gabor Kelemen
Modified: 2019-05-15 08:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Word (19.80 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-11-22 14:52 UTC, Gabor Kelemen
Details
Screenshot of the original document side by side in Word and Writer. (174.64 KB, image/png)
2018-11-22 14:53 UTC, Gabor Kelemen
Details
Screenshot of the problem side by side in Word and Writer. (196.49 KB, image/png)
2018-11-22 14:53 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-11-22 14:52:34 UTC
Created attachment 146909 [details]
Example file from Word

Create a list and a paragraph in Word. Turn on track changes and delete the last item of the list. 
If we hide recorded changes in LibreOffice Writer, then the paragraph will become part of the list.

Steps to reproduce:

    1. Create a new document in Microsoft Word 2010.
    2. Type two paragraphs.
    3. Select the first paragraph.
    4. On the Home tab, in the Paragraph group, choose Bulleted List.
    5. On the Review tab, in the Tracking group, choose Track Changes.
    6. Delete the first paragraph.
    7. Save the file as DOCX.
    8. Open the same file in LibreOffice Writer.
    9. Choose Edit → Track Changes, disable Show.


Actual results:
The paragraph's formatting changed: the second paragraph became part of the bulleted list.

Expected results:
The paragraph's formatting shouldn’t change.


LibreOffice details:
Version: 6.3.0.0.alpha0+
Build ID: d71ea82055a6a304493c7eaa90809a348e23784d
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-11-19_03:25:07
Locale: en-US (hu_HU); UI-Language: en-US
Calc: threaded
Comment 1 Gabor Kelemen 2018-11-22 14:53:20 UTC
Created attachment 146910 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 2 Gabor Kelemen 2018-11-22 14:53:43 UTC
Created attachment 146911 [details]
Screenshot of the problem side by side in Word and Writer.
Comment 3 Timur 2018-11-22 16:15:30 UTC
Repro. Looks inherited from OO, was even worse.
Comment 4 László Németh 2019-05-15 08:28:58 UTC

*** This bug has been marked as a duplicate of bug 118699 ***