Bug Hunting Session
Bug 121705 - Select multiple tables in a Writer document
Summary: Select multiple tables in a Writer document
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Writer-Tables-Enhancements
  Show dependency treegraph
 
Reported: 2018-11-25 18:30 UTC by Juan Hernandez
Modified: 2019-01-21 11:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Hernandez 2018-11-25 18:30:55 UTC
I work a lot with tables. Unfortunately, in Writer, there is no way to select multiple tables with Ctrl or something like that, in order to apply for example the same style to all tables. I work with hundreds of tables in the same document. It is mandatory for me to get this feature in LibreOffice Writer. Because of this lack, I made this process in MSOffice and come back to Writer. 

Than's in advance
Comment 1 Dieter Praas 2018-11-25 21:21:08 UTC
I focus on the possibility to change table style for all tables. I confirm that this it not possible but a useful feature.

Actual result: Only the style of the first table changes.

But let's ask design team.
Comment 2 Heiko Tietze 2018-11-26 12:06:12 UTC
The scenario is to select everything per ctrl+a and, likewise the paragraph style being applied to all text, this should work for tables. But OTOH you can press ctrl+a within a table to select all cells, which is pretty convenient. The same is true for mouse selection and a ctrl+click selection method is not feasible. 

I have also doubts about the usefulness to set one style to all text- usually there are headings, at least. So my take here is WF as the proposed workflow is to define a table style at the beginning and use it across the document. When you change this table style later it affects all occurrences.

But let's keep the topic open a while for other opinions.
Comment 3 Juan Hernandez 2018-11-26 12:33:13 UTC
Sorry but ctrl +a in linux at least implies activating the menu to open a file. 
Anyway, let's suppose we need to copy 20 specific tables from a total of 100 or more (as an example). There is no way to do this in Writer (that I know of). In my previous bug report I have given just an example of applying a style to many tables as a mere example of something simple, that can't be done. The list of possible uses of this requested feature could be endless.  In fact I am forced (to my regret) to perform all these actions outside of Writer. I refuse to copy each table one at a time. I work with hundreds of tables in each document.
Comment 4 Dieter Praas 2018-11-26 13:27:51 UTC
(In reply to Heiko Tietze from comment #2)
> The scenario is to select everything per ctrl+a and, likewise the paragraph
> style being applied to all text, this should work for tables.

I agree that it should work, but it doesn't. Only the style of the first table changes.

@Juan: Since there should be only one issue per bug, it might be useful to focus on this topic here and perhaps open new bug for further enhancement proposals.
Comment 5 Heiko Tietze 2018-11-26 21:11:19 UTC
(In reply to Juan Hernandez from comment #3)
> Sorry but ctrl +a in linux at least implies activating the menu to open a
> file. 

Ctrl+a is the shortcut to select everything on all operating systems. I tried to explain the supposed workflow and why multiselect wont fix the issue (or rather introduce new problems). Maybe a macro helps you to apply the table style to all those objects.
Comment 6 Juan Hernandez 2018-11-26 21:34:45 UTC
I have asked for the possibility of selecting multiple tables in Writer and perhaps I have given an uninteresting example that demonstrates that need. 
Actually, applying styles to multiple tables is the part that interests me the least. I particularly work with hundreds of tables in a document and it is very common to select only a few (20, 30, etc) of the hundreds of tables in it. At the moment that is something impossible to do in Writer. Maybe it's just something that I just need as a user and it's not worth the effort. In any case, I very much doubt that it is not, in fact, something that many users miss.
Comment 7 Haoyu 2018-11-29 08:30:58 UTC
Bug confirmed
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded
Comment 8 Heiko Tietze 2018-11-30 10:14:53 UTC
Discussed this topic at the ESC talkl yesterday and devs are rather pessimistic regarding feasibility. From the UX POV I can imagine to click one table and another on the same page but not 20. A possible solution could be the Navigator listing tables separately and you select only those objects in this list. Though, what do you do then? I mean copy/paste without surrounding text sounds not like a common use case and applying a style after inserting is not the supposed workflow. As said before you also don't select all text paragraphs only and change the style from Default to Text Body.

So while the issue is clear the recommendation is to format properly in the first place or create an extension for this special use case (applying a style rather than multi selection). Shouldn't be too hard to iterate over the document and apply a certain table style to objects. We have a very friendly community keen to help you with this at askbot.