Download it now!
Bug 121749 - problem downloading beta file
Summary: problem downloading beta file
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-28 06:30 UTC by moisele
Modified: 2018-12-24 15:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
error message when downloading (123.16 KB, image/png)
2018-11-28 06:30 UTC, moisele
Details
website (98.88 KB, image/png)
2018-12-02 03:51 UTC, moisele
Details
MDS checksum (51.46 KB, image/png)
2018-12-20 17:49 UTC, moisele
Details
final message (26.00 KB, image/png)
2018-12-21 01:21 UTC, moisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description moisele 2018-11-28 06:30:27 UTC
Created attachment 147082 [details]
error message when downloading

see attached
Comment 1 Xisco Faulí 2018-11-28 10:59:05 UTC
Hello,
Could you please try to download it again?
OTOH, are you installing it from an external harddisk or a CD-ROM ?
Comment 2 moisele 2018-11-30 01:26:40 UTC
problem repeated. 
I deleted the first installation file before downloading again. 
I'm downloading to a 64 bit Windows 7 Ultimate laptop.
Comment 3 Aron Budea 2018-12-02 02:55:47 UTC
Can you give the size of the downloaded file, and the link of the mirror it was downloaded from?
Comment 4 moisele 2018-12-02 03:51:43 UTC
Created attachment 147214 [details]
website

please see attachment. I hope this answers most of your question. 
i'm sorry, I don't know how to answer the size question.
Comment 5 Xisco Faulí 2018-12-17 12:21:55 UTC
Hello,
Thank link point to https://downloadarchive.documentfoundation.org/libreoffice/old/6.2.0.0.beta1/win/x86_64/LibreOfficeDev_6.2.0.0.beta1_Win_x64.msi which works...
Do you still face the problem ?
Comment 6 moisele 2018-12-17 17:55:18 UTC
I redownloaded using the link provided and attempted installation 3x. 
1. same error as always 
2. failed to initiate installation. 
3. same error as always. no change 
end result: unable to install program.
Comment 7 Mike Kaganski 2018-12-20 06:02:41 UTC
(In reply to moisele from comment #6)

Hi! I understand that you have some unpleasant experience with this issue; but may I ask you a favor: since you have a reliably reproducible behavior here, you could help us to nail down at least this specific case of the problem.

At [1], there is an information about the package you have downloaded and tried to install a number of times. I suppose that, since the same package was downloaded and installed successfully a big number of times by others, and since there's no other mirror for the package offered from [1], the package itself is OK. So the problem must be somewhere on the transfer or on your side, and finding it could help others to avoid it in the future - thus your help would be very valuable. Thanks!

Could you please:

1. Check that the downloaded package has the same hash (SHA256/SHA1/MD5) as mentioned on the page [1]? Multiple tools can do that; e.g., 7-zip has this function included (at least, recent versions). This step helps to rule out a possibility of in-transfer corruption; this problem is actually unlikely, since if it were that, it wouldn't go as far as to checking the embedded .cab - it would say that MSI itself is corrupt instead.

2. If you are running any antivirus software (like Windows Defender, or Kaspersky/Norton/Avast/etc products), check if disabling the software for the time of installation solves the problem. This could help to exclude the possibility of the AV interfering with the process.

3. Check if any suspicious Windows logs are recorded at the time of the installation. Please check Computer Management applet (accessible by right-clicking "My Computer" in Windows Explorer) -> Events, both Computer and Application logs (and possibly others as well), for the time frame of the installation attempt.

4. Check if other LibreOffice packages install OK. Recently, LibreOffice 6.1.4 release was announced [2]; could you please try downloading [3]installing that to check if the same problem happens with that or not. Also, to check a different package of a comparable size, you could also test if installing an Apache OpenOffice [4] succeeds or not. This step tries to check somehow if this is a generic problem related to e.g. memory corruption on your system or somesuch (of course, this test is not definitive, and may point to a different cause, or may pass and still conceal an existing such problem).

5. Ideally, a hardware test.

Thanks for doing any set of the above list and coming back with results. Doing that could be of help to people suffering from a similar problem, as in bug 79091.

[1] http://downloadarchive.documentfoundation.org/libreoffice/old/6.2.0.0.beta1/win/x86_64/LibreOfficeDev_6.2.0.0.beta1_Win_x64.msi.mirrorlist
[2] https://blog.documentfoundation.org/blog/2018/12/18/libreoffice-6-1-4-announced/
[3] https://www.libreoffice.org/download/download/
[4] http://www.openoffice.org/download/index.html
Comment 8 moisele 2018-12-20 16:49:45 UTC
If anyone wants to know, I'm running a previously installed LibreOffice version: 6.1.2.1 (x64) with no problems (prior to, during, and after the time of the installation issue). I'm happy to be of whatever help I can be. I shall attempt the things requested asap and report when applicable and/or request more info concerning the directions.
Comment 9 moisele 2018-12-20 17:49:51 UTC
Created attachment 147720 [details]
MDS checksum
Comment 10 moisele 2018-12-20 17:52:07 UTC
MDS:   1363A351E8F93D9BB2CEFBD32E2A32C3
CRC: 3753109131
SHA1: C9333CA30195D8C06FDCB63B8F12E0E1FBDB7D9C

I have no idea what I'm doing and happy to be of assistance. Please inform if checksum does not answer the question that was asked.
Comment 11 Mike Kaganski 2018-12-20 19:11:15 UTC
(In reply to moisele from comment #10)
> MDS:   1363A351E8F93D9BB2CEFBD32E2A32C3
> CRC: 3753109131
> SHA1: C9333CA30195D8C06FDCB63B8F12E0E1FBDB7D9C

I must say that my
> this problem is actually unlikely,
> since if it were that, it wouldn't go as far as to checking the embedded
> .cab - it would say that MSI itself is corrupt instead.
is clearly wrong. In fact, you have a broken package. The on-server image has e.g. SHA1 hash 3b3ce8b74c7f754802620117ca880d90a16e0e35. So it's likely a problem of your downloader. Which program do you use to download?
Comment 12 moisele 2018-12-20 21:24:52 UTC
As far as I can determine, antivirus (Microsoft Security Essentials and Malwarebtyes, including windows defender) is not an issue in installation. I turned them off using task manager. 

The event log does not, to my knowledge, record any issues with installation. I couldn't remember installation dates and times , so I ran installation 2x and checked the event log. nothing.  The most recent event long was an error that occurred 21 hours ago. 

When I right click on the installation file I get an option to "scan with Malwarebyes" and "troubleshoot compatibility", neither of which resolves the problem. 

I ran a windows diagnostic on the RAM memory with no recorded issues. 

Device Manager reveals no problems or issues. 

Performance Monitor has no reports.  

I tried to download Apace Office, but I have insufficient space on my laptop for installation.  The Beta version does not indicate file size nor provide an option as to where it can be installed. I have 3 drives, so I can't switch to another drive. 

I placed the installation file on a memory stick and on an exterior, attached (previous) harddisk, and attempted installation; received the same error message. However, this time Microsoft Security Essentials (which was running at this time) objected saying something about it cleansing the file.
Comment 13 moisele 2018-12-20 21:29:49 UTC
Please tell me how I can answer your question: "Which program do you use to download?" I click on the link provided, it downloads an installer, not a zip package, and when the download is complete, I run the installer, which I'm guessing downloads the software from the internet. If you tell me how to determine what program I use to download, I'd be happy to answer your question. (sorry to be so ignorant. Please educate me).
Comment 14 moisele 2018-12-20 21:50:49 UTC
I don't know if this is useful info or not, but I find it funny that when it's downloading, it announces the download time and the time changes a lot. It will say things like it will take 16 hours to download. I haven't timed it but I'd be surprised if it took more than 20 minutes.
Comment 15 moisele 2018-12-21 01:19:48 UTC
Please see attached. took hours to download in Google Chrome.
Comment 16 moisele 2018-12-21 01:21:23 UTC
Created attachment 147726 [details]
final message
Comment 17 Mike Kaganski 2018-12-21 05:31:25 UTC
(In reply to moisele from comment #13)
> Please tell me how I can answer your question: "Which program do you use to
> download?" I click on the link provided, it downloads an installer

Please describe in which program (which browser) do you click the link provided? does the download appear in the same browser (as a notification/icon) when finished? Please tell the name of the browser and its version (usually some kind of Help->About menu).

> and when the download is complete, I run the installer, which
> I'm guessing downloads the software from the internet.

The latter is not correct: the installer contains everything inside (it's 285 MB), and does not download anything from Internet itself.
Comment 18 moisele 2018-12-21 15:29:22 UTC
thank you for the education. much appreciated. glad to know the installer contains everything. Epic Browser has been removed from my machine.
Comment 19 moisele 2018-12-21 15:31:30 UTC
Also glad for all the things I learned along the way--the checksum, the RAM check, and everything. It's been a good learning experience. I just feel bad for unintentionally causing the whole problem in the first place. Thank you for being proactive and helping me fix it and thank you for LibreOffice and the beta version!