Download it now!
Bug 121773 - EDITING: hang if i insert an hyperlink in a multi-line text in a shape
Summary: EDITING: hang if i insert an hyperlink in a multi-line text in a shape
Status: RESOLVED DUPLICATE of bug 118967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-28 21:11 UTC by palmierivinc.ent
Modified: 2018-11-28 22:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description palmierivinc.ent 2018-11-28 21:11:47 UTC
Description:
When i try to put an hyperlink on a multi-line text in a simple shape, libreOffice freezes.

Steps to Reproduce:
To reproduce this bug:
1. Create a new document, with Writer for example,
2. Draw a basic shape, such as a rectangle,
3. Write some multi-line text in this shape,
4. Select this text and open the hyperlink dialog with Ctrl + K,
5. Put some URL and validate.

Actual Results:
LibreOffice freezes. Waiting doesn't change anything, I have to kill it.

Expected Results:
LibreOffice does not freeze and give me a multi-line hyperlink.


Reproducible: Always


User Profile Reset: No



Additional Info:
I experiment the same issue with Writer, Calc, Draw and Impress.
Comment 1 Xisco Faulí 2018-11-28 22:29:48 UTC
This is fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=6b669c9d9ee61c5c37c384c3a546467a048f5636 which is reported in bug 118967 and it should be fixed in LibreOffice 6.2
Thanks for reporting the issue.
Closing as a duplicate of bug 118967

*** This bug has been marked as a duplicate of bug 118967 ***