Download it now!
Bug 121809 - FEATURE REQUEST: Sheets for Writer (like in Calc) to separate document contents into categories etc.
Summary: FEATURE REQUEST: Sheets for Writer (like in Calc) to separate document conten...
Status: RESOLVED DUPLICATE of bug 33173
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL: https://www.technorms.com/wp-content/...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-29 21:36 UTC by Stian
Modified: 2019-10-23 21:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stian 2018-11-29 21:36:20 UTC
Description:
This is a feature request for sheets for Writer. This functionality can already be found in Calc (and Excel) but would be very useful in Writer!

The sheet functionality would be perfect for this! I suppose the source code is easily adaptable from Calc to Writer.

Picture of the functionality in Calc for illustration (sheets at the bottom left): https://www.technorms.com/wp-content/uploads/2011/12/Libre-Office-Calc.png

Actual Results:
This is a feature request. The feature does not exist.

Expected Results:
It should exist. :)


Reproducible: Always


User Profile Reset: No



Additional Info:
Why the need? To separate categories, topics etc. in documents. For instance, I have documents where I gather information on tuning parts, mods and reference information. Categories being suspension, brakes, wheels, electronics, weight reduction, you get the point. Other examples being system rebuild references (settings, fixes for problems, software, links and information).

I'm aware of this Superuser thread of someone else asking for it, does not solve the problem for neither of us: https://superuser.com/questions/978787/sheets-in-libreoffice-writer-similar-to-that-in-calc
Comment 1 Dieter 2018-11-29 22:01:00 UTC
I think that's a question for the design team => needsUXEval
Comment 2 V Stuart Foote 2018-11-29 22:09:36 UTC
See little need to implement this non-ODF compliant Text document mode. Every thing the OP is asking for can be handled with master document / sub-document(s)--managed from Navigator.

Somewhat lighter weight is to work with Sections in a single Writer document, again managed from Navigator.

IMHO = WF
Comment 3 Stian 2018-11-29 22:22:52 UTC
V Stuart Foote:
I'd argue a master document and subdocuments are cumbersome to use and don't suit the purpose very well. The sheet functionality in Calc fit the purpose perfectly when you need to go back and forth all the time to insert and view info. It's also contained within one file.

I suspected it wouldn't comply with the file format. To that, I say it doesn't have to and could be saved to an ODF-extended format. I wouldn't mind if it were an opt-in functionality (intentionally enabled by user) and would only support viewing and editing in Libre Office.
Comment 4 V Stuart Foote 2018-11-29 22:40:53 UTC

*** This bug has been marked as a duplicate of bug 33173 ***
Comment 5 V Stuart Foote 2019-03-12 16:49:03 UTC
QA housekeeping adjusting the duplicate to bug 37134 from bug 33173

*** This bug has been marked as a duplicate of bug 37134 ***
Comment 6 David 2019-10-23 20:45:31 UTC
This is a duplicate of bug 33173 tab per section, not 37134 tab per document.

*** This bug has been marked as a duplicate of bug 37133 ***
Comment 7 V Stuart Foote 2019-10-23 21:01:52 UTC
that of course was bug 33173 not 37133...

*** This bug has been marked as a duplicate of bug 33173 ***