Download it now!
Bug 121857 - Ability to interactively size and position Table when creating
Summary: Ability to interactively size and position Table when creating
Status: RESOLVED DUPLICATE of bug 113603
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Enhancements
  Show dependency treegraph
 
Reported: 2018-12-02 08:15 UTC by 34.rsreddy
Modified: 2018-12-03 11:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 34.rsreddy 2018-12-02 08:15:32 UTC
Description:
In table menu insert table option is present.Draw table option in not available like in microsoft office.So we can't draw a table as our need.Also erase option should present in libre office.In draw table option a pencil should appear by which we can drag tables ourselves. 

Steps to Reproduce:
1.Table menu - insert table- draw table
2.
3.

Actual Results:
Can't draw tables as our need

Expected Results:
We can draw tables , letters etc.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
In table menu insert table option is present.Draw table option in not available like in microsoft office.So we can't draw a table as our need.Also erase option should present in libre office.In draw table option a pencil should appear by which we can drag tables ourselves.
Comment 1 34.rsreddy 2018-12-02 08:17:18 UTC
Please create a new option like in table menu by which we can draw table .
Comment 2 Roman Kuznetsov 2018-12-02 11:07:00 UTC
are you sure that your bug is about Documentation?
Comment 3 V Stuart Foote 2018-12-02 16:25:52 UTC
The "moveable" tables the OP requests require encapsulation within an object frame, and are not table inserted directly to document canvas and controlled by page layout.

This is trivial to do already, but requires a two step approach of creating the frame to hold the new table.

1. create the frame, Insert -> Frame -> Frame Interactively, setting it to the size needed.

2.position focus into the frame, insert table. With <Ctl>+F12 dialog, or the Button GUI widget from the standard toolbar.

The Frame can be resized, anchored, moved, and styled. And Table can be resized and styled inside the frame.

And on current master/6.3.0 builds -- the Table -> Size, Row and Column controls have been reworked to give correct distribution(s) within the frame.

So, while there would be some utility to a single UNO control to consolidate these steps as a menu or button action, it is not urgent.
Comment 4 Heiko Tietze 2018-12-03 11:52:24 UTC
There is a similar request in bug 113603 with the proposal to have more interactive option as known from iWorks. Meanwhile Stuart's "workaround" is the LibreOffice way of dealing with the size.

*** This bug has been marked as a duplicate of bug 113603 ***