Bug 121887 - FILEOPEN XLSX "Maximum number of rows per sheet" on tags ROW without attribute R
Summary: FILEOPEN XLSX "Maximum number of rows per sheet" on tags ROW without attribute R
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-12-03 19:53 UTC by Maxim Britov
Modified: 2018-12-06 13:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Really small example for the issue (2.38 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-12-03 19:53 UTC, Maxim Britov
Details
same file with r="1" attribute added (2.38 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-12-03 19:55 UTC, Maxim Britov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Britov 2018-12-03 19:53:30 UTC
Created attachment 147249 [details]
Really small example for the issue

We have reports in XLSX from our corporate GSM oprtaror.
Everytime we open that files in LO we have warning about maximum rows exceeded.
Today I spent 2-3 hours to track down this issue.

I found LO warn "Maximum number of rows per sheet" on this simple XML:

<sheetData>
    <row> <c><v>1</v></c> </row>
</sheetData>

with attribute R it eats file fine:

<sheetData>
    <row r="1"> <c><v>1</v></c> </row>
</sheetData>

But Excel (2003, 2007, web 365) open file fine without any warnings and issues.

Tested on 6.0.7.3 and 6.1.3.2
Comment 1 Maxim Britov 2018-12-03 19:55:04 UTC
Created attachment 147250 [details]
same file with r="1" attribute added
Comment 2 Maxim Britov 2018-12-04 08:26:20 UTC
6.0.2.1 unaffected
6.0.3.2 affected
Comment 3 raal 2018-12-04 19:44:25 UTC
This seems to have begun at the below commit.
Adding Cc: to Eike Rathke ; Could you possibly take a look at this one?
Thanks

c30e1d5f5248dff3465e6a25aba76282317268f8 is the first bad commit
commit c30e1d5f5248dff3465e6a25aba76282317268f8
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Mar 1 14:20:29 2018 +0100

    source sha:66564dac88ffcc781b4fade7ca0f4f72af6b8bca
 
author	Eike Rathke <erack@redhat.com>	2018-02-28 22:39:30 +0100
committer	Eike Rathke <erack@redhat.com>	2018-03-01 13:16:56 +0100
commit	66564dac88ffcc781b4fade7ca0f4f72af6b8bca (patch)
tree	8214347cd6fe0beb19f1ae60f2fb24e2460663fa
parent	18b4c1d0b8e030e4fa081995eccf68f01049892e (diff)
Resolves: tdf#114555 check .xlsx col/row/tab overflow and display warning
Comment 4 Eike Rathke 2018-12-04 21:44:27 UTC
Turns out this was always wrong and the very first row model not applied if no r=... row number given, but previously didn't raise a message.. need to investigate what the proper fix will be in the context of 1-based vs 0-based row models.
Comment 5 Eike Rathke 2018-12-04 21:57:31 UTC
And btw thanks for this minimal test case!
Comment 6 Commit Notification 2018-12-05 16:08:03 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/76fbe494785faee1313d1c0be8ed2ca7b0d74f68%5E%21

Resolves: tdf#121887 RowModel::mnRow is 1-based, always

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Eike Rathke 2018-12-05 16:10:48 UTC
Pending review
https://gerrit.libreoffice.org/64638 for 6-2
https://gerrit.libreoffice.org/64639 for 6-1
https://gerrit.libreoffice.org/64640 for 6-1-4
Comment 8 Commit Notification 2018-12-05 21:44:08 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/8f237e07a08abf703e0da15030bd708fde28e616%5E%21

Resolves: tdf#121887 RowModel::mnRow is 1-based, always

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-12-05 22:02:16 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/41f19175c2e4c344c582c8b57a803f5ec4e5aaad%5E%21

Resolves: tdf#121887 RowModel::mnRow is 1-based, always

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Maxim Britov 2018-12-06 10:50:50 UTC
Thanks. Fixed on my 6.0.7.3 with patch applied.
Comment 11 Commit Notification 2018-12-06 11:59:31 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-1-4":

https://git.libreoffice.org/core/+/7c761ae3d363d6763dc182dd4481a9780521d9ed%5E%21

Resolves: tdf#121887 RowModel::mnRow is 1-based, always

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2018-12-06 13:10:53 UTC
(In reply to Maxim Britov from comment #10)
> Thanks. Fixed on my 6.0.7.3 with patch applied.

Thanks for checking. Setting to VERIFIED.
@Eike, thanks for the quick fix!