Download it now!
Bug 121954 - BASIC: inputbox layout modified
Summary: BASIC: inputbox layout modified
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0.1 target:6.3.0 target:6.1.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-12-07 06:33 UTC by tommy27
Modified: 2018-12-11 11:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
inputbox in 6.0.x (18.84 KB, image/jpeg)
2018-12-07 06:34 UTC, tommy27
Details
inputbox in 6.1.x (14.01 KB, image/jpeg)
2018-12-07 06:34 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2018-12-07 06:33:41 UTC
Description:
I don't know if this change was intended or it's a side effect of some other GUI change.
anyway the new BASIC inputbox layout in 6.1.x looks different thant 6.0.x
check screenshots.

Steps to Reproduce:
try this macro and see the different layout in 6.0.x and 6.1 x

sub Inputbox
InputBox("box text ","box titlebar",)
end sub

Actual Results:
- in 6.0.x the box test was on a line and the inputbox at the bottom; it was confortable if you had long "box text descriptions" and long "manual text" to digit

- in 6.1.x the box test and the inputbox are in the same line so if you work with long texts it's quite annoying

Expected Results:
please, bring back the old layout.

reproduced in LibO 6.1.3 under Win10 x64 and Win7 x64
not reproduced in LibO 6.0.6
hence regression


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 tommy27 2018-12-07 06:34:31 UTC
Created attachment 147339 [details]
inputbox in 6.0.x
Comment 2 tommy27 2018-12-07 06:34:58 UTC
Created attachment 147340 [details]
inputbox in 6.1.x
Comment 3 raal 2018-12-07 12:23:27 UTC
Confirm. I'll bibisect it later.
Comment 4 raal 2018-12-07 15:06:07 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara; Could you possibly take a look at this one? Thanks

40ead0861a80de50c5a731a02c945a21d5738e33 is the first bad commit
commit 40ead0861a80de50c5a731a02c945a21d5738e33
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Apr 12 22:11:52 2018 -0700

    source sha:6672151fbb6865415b4036525c13c182590369c9
authorCaolán McNamara <caolanm@redhat.com>2018-04-11 21:41:35 +0100 committerCaolán McNamara <caolanm@redhat.com>2018-04-12 10:52:01 +0200 commit6672151fbb6865415b4036525c13c182590369c9 (patch) treee7060de436c5d3aeae0e84eddf8c8173c1724206 parentb00815b58a602c19a980c0142f7b9462b8faffd2 (diff)
weld SvRTLInputBox
This (forgotten) dialog is the statbasic "InputBox" dialog
Comment 5 tommy27 2018-12-07 17:56:27 UTC
yes, Caolán revamped many dialogs.
maybe this was intended but maybe is a side effect of some UI code changes.

in my scenario the new imputbox layout is worse than before expecially if you have longer text than those I put in the screenshot mockups
Comment 6 Commit Notification 2018-12-07 21:12:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/5fe19e3e52ba15a8db0bb8d982ee50c5d3ac3a17%5E%21

Resolves: tdf#121954 basic input box used to have label on top of entry

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-12-07 21:12:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/74dd206e67c2efb1e56d817be9e42a1ed82e3239%5E%21

Resolves: tdf#121954 basic input box used to have label on top of entry

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2018-12-07 21:18:28 UTC
backport to 6-1 in gerrit
Comment 9 Xisco Faulí 2018-12-11 11:41:24 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 0ad2302cf6787cacbbaca081a890a0e356a55297
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, Thanks for fixing this!!
Comment 10 Commit Notification 2018-12-11 11:45:42 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/b82390c53105a0c62e0524a1cc833ed8389b9a95%5E%21

Resolves: tdf#121954 basic input box used to have label on top of entry

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.