Download it now!
Bug 121971 - kde5: Sidebar option texts not correctly shown
Summary: kde5: Sidebar option texts not correctly shown
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-12-08 00:26 UTC by Michael Weghorn
Modified: 2019-02-19 11:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot kde5 (broken) (45.90 KB, image/png)
2018-12-08 00:27 UTC, Michael Weghorn
Details
Screnshot gtk3 (OK) (55.71 KB, image/png)
2018-12-08 00:27 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2018-12-08 00:26:08 UTC
This is specific to the kde5 VCL plugin. It works as expected when using e.g. the gtk3 VCL plugin instead.

Version: 6.3.0.0.alpha0+
Build ID: cb52b112c0d44d7a6849f773fd1ee4e863ab91da
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Steps to reproduce:

1) Start Writer
2) click the top-level item in the (collapsed) sidebar (labelled "Sidebar" as well)

Result: Some checkboxes appear at the very right-hand side of the screen, but no proper texts/labels are shown

Expected result: The checkbox labels ("Properties", "Page", "Styles", "Gallery", "Navigator") and the texts for "Undock", "Close Sidebar", and "Customization" are displayed as well.
Comment 1 Michael Weghorn 2018-12-08 00:27:27 UTC
Created attachment 147367 [details]
Screenshot kde5 (broken)

Screenshot that shows the issue (look at the top right)
Comment 2 Michael Weghorn 2018-12-08 00:27:53 UTC
Created attachment 147368 [details]
Screnshot gtk3 (OK)
Comment 3 Vera Blagoveschenskaya 2018-12-16 13:59:16 UTC
Hello, Michael,

I can't reproduce this behavior for build

Version: 6.3.0.0.alpha0+
Build ID: e3e15d8c625cbf56e1f03d9ebde966e78844c7a4
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-12-13_20:10:25
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Possibly it was fixed with another bug?..

Could you please re-check?
Comment 4 Michael Weghorn 2018-12-16 16:34:45 UTC
(In reply to Vera Blagoveschenskaya from comment #3)
> Could you please re-check?

Retesting showed that it works *sometimes*; more precisely:

* It works when using just a single screen.
* In a dual-screen setup where the right screen is the main screen:
  * It works OK when the Writer window is maximized on the left screen.
  * The problem is still reproducible when the writer Window is maximized on the right screen.

Testing was done on Debian testing (with the 'plasma-desktop' package at version 4:5.14.3-1).
Comment 5 Michael Weghorn 2019-02-19 11:43:32 UTC
I can no longer reproduce with

Version: 6.3.0.0.alpha0+
Build ID: 993b8a6667fb0ca58ec1145cc1f9529c34f3266c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

-> WORKSFORME

The texts are shown correctly now.
(What's not perfect yet is that checkboxes and radiobuttons are a little cut off at the right-hand side, but that seems to be another issue.)