Download it now!
Bug 121975 - kde5: Impress shows "debug information" on presentation screen as well
Summary: kde5: Impress shows "debug information" on presentation screen as well
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-12-08 03:08 UTC by Michael Weghorn
Modified: 2018-12-19 15:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of both screens (90.13 KB, image/png)
2018-12-08 03:08 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2018-12-08 03:08:43 UTC
Created attachment 147371 [details]
Screenshot of both screens

This is specific to the kde5 VCL plugin. It works as expected when using e.g. the gtk3 VCL plugin instead.

Version: 6.3.0.0.alpha0+
Build ID: cb52b112c0d44d7a6849f773fd1ee4e863ab91da
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Steps to reproduce:

0) have a dual screen setup
1) open an Impress presentation or create a new one
2) start presentation mode (F5)
3) click to actually start presentation (due to bug 119718)
4) have a look at output on both screens

Result: Both screens show "debug" information like "fps", "Sprites" and "Mem" (though they have different data...), s. attached screenshot

Expected result: These data should only be shown on the screen showing the presenter console, not on the actual presentation screen that the potential audience can see.
Comment 1 Thorsten Behrens (CIB) 2018-12-19 06:16:25 UTC
That works as intended - in builds that set OSL_DEBUG_LEVEL > 0, the vclcanvas shows that extra info (code is canvas/source/vcl/spritecanvashelper.cxx:129)
Comment 2 Michael Weghorn 2018-12-19 15:34:22 UTC
(In reply to Thorsten Behrens (CIB) from comment #1)
> That works as intended - in builds that set OSL_DEBUG_LEVEL > 0, the
> vclcanvas shows that extra info (code is
> canvas/source/vcl/spritecanvashelper.cxx:129)

Interestingly, gtk3 only shows it on the screen that shows the presenter console. :-)
However, no problem for me as long as it doesn't happen for production builds.