Bug 122005 - Firebird migration assistant causes SIGSEGV on first opening of a query
Summary: Firebird migration assistant causes SIGSEGV on first opening of a query
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Database-Firebird-Migration
  Show dependency treegraph
 
Reported: 2018-12-10 10:30 UTC by Alex Thurgood
Modified: 2019-07-17 10:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
LLdb backtrace on SIGSEGV (56.76 KB, text/plain)
2018-12-10 10:32 UTC, Alex Thurgood
Details
Test ODB (28.17 KB, application/vnd.oasis.opendocument.database)
2018-12-13 11:11 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2018-12-10 10:30:46 UTC
Description:
1) In a developer version of LibreOffice, e.g. master or daily build, with the Experimental Features activated.

2) Open a hsqldb embedded database.
3) Double-click on a query or a form based on a query.
4) The Migration Dialog assistant message appears. Click on "Later"
5) SIGSEGV



Steps to Reproduce:
See above

Actual Results:
Starting the migration assistant causes a SIGSEGV.

Expected Results:
The migration assistant should not cause a SIGSEGV, and should proceed without error.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Alex Thurgood 2018-12-10 10:32:22 UTC
Created attachment 147412 [details]
LLdb backtrace on SIGSEGV

Enclosing Apple lldb backtrace when SIGSEGV occurs.
Comment 2 Alex Thurgood 2018-12-10 10:34:09 UTC
Tested on 

Version: 6.3.0.0.alpha0+
Build ID: 8ec5c249fc40fb80d2a00e54a0bd76451dbc6477
CPU threads: 4; OS: Mac OS X 10.14.1; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 raal 2018-12-10 16:44:39 UTC
No crash on linux Version: 6.3.0.0.alpha0+
Build ID: 1ee8d4f63adf3113a4733a479c8faf9eb65f7b8d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 4 Alex Thurgood 2018-12-12 11:33:29 UTC
(In reply to raal from comment #3)
> No crash on linux Version: 6.3.0.0.alpha0+
> Build ID: 1ee8d4f63adf3113a4733a479c8faf9eb65f7b8d
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;

I'm guessing that this is specific to Mac, and maybe even specific to macOS 10.14
Comment 5 Xisco Faulí 2018-12-12 17:42:10 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 1f2d3b3f09d16033dae1f99f7739564a5f4c5482
CPU threads: 8; OS: Mac OS X 10.14.1; UI render: default; VCL: osx; 
Locale: en-US (en_ES.UTF-8); UI-Language: en-US
Calc: threaded

which document are you using ? Please share it
Comment 6 Alex Thurgood 2018-12-13 11:11:53 UTC
Created attachment 147492 [details]
Test ODB

Enclosing test file.

1) Start LODev in lldb.
1) Load ODB file
2) On Queries, double-click on qry_DATE

This is with my master build 

Version: 6.3.0.0.alpha0+
Build ID: 3911bf8364dae4c855ad37237c114f9007f70657
CPU threads: 4; OS: Mac OS X 10.14.1; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

from 12/12 with clean profile.
Comment 7 Drew Jensen 2019-01-01 15:30:20 UTC
(In reply to Alex Thurgood from comment #6)
> Created attachment 147492 [details]
> Test ODB
> 
> Enclosing test file.
> 
> 1) Start LODev in lldb.
> 1) Load ODB file
> 2) On Queries, double-click on qry_DATE
> 
> This is with my master build 
> 
> Version: 6.3.0.0.alpha0+
> Build ID: 3911bf8364dae4c855ad37237c114f9007f70657
> CPU threads: 4; OS: Mac OS X 10.14.1; UI render: default; VCL: osx; 
> Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> from 12/12 with clean profile.

I was not able to recreate a crash during migration under Ubuntu and don't have a osx system to try it on.

However, this issue https://bugs.documentfoundation.org/show_bug.cgi?id=121838 which covered a similar problem was closed after a patch.

Could you try the latest build with that file.

BTW - the file migrated without an error, but there is at least one data issue, the postalcode field is of type DECIMAL and the data is mangled on migration.
Comment 8 Alex Thurgood 2019-01-04 08:57:21 UTC
Still reproducible for me with my symbols enabled build - could this be a debug-build only issue ?

* thread #1, queue = 'com.apple.main-thread', stop reason = signal SIGSEGV
    frame #0: 0x00000001940614f3
->  0x1940614f3: movl   (%rsi), %eax
    0x1940614f5: leaq   0x30(%rbp), %rsi
    0x1940614f9: movl   $0x10000, %eax            ; imm = 0x10000 
    0x1940614fe: andl   0x4(%rsi), %eax
Target 0: (soffice) stopped.
(lldb) c
Process 96869 resuming



It only happens the very first time that the query is launched. Subsequent closing and re-opening of the query don't produce a SIGSEGV.

Version: 6.3.0.0.alpha0+
Build ID: 608cd2cfe9c82855360c94d629eaac7a76ae212a
CPU threads: 4; OS: Mac OS X 10.14.2; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Alex Thurgood 2019-07-17 10:31:06 UTC
Don't seem to be able to reproduce this anymore.