Bug 122011 - Support for referring to tables from external files
Summary: Support for referring to tables from external files
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:6.4.0 target:6.3.3
Keywords: regression
Depends on:
Blocks: Chart-Wizard Chart-Enhancements
  Show dependency treegraph
 
Reported: 2018-12-10 14:11 UTC by Markus Elfring
Modified: 2019-10-21 08:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Elfring 2018-12-10 14:11:53 UTC
It is described that a cell can be referenced from another document for a formula.
I have tried out to specify a file name also for a data range on the page “Chart wizard: 2. Data ranges”. But it seems that this specification is not accepted so far. (The background colour became red in the text field “Data range”.)

How do you think about to retrieve required data from external files here (instead of putting diagrams only into the same document of the data source)?
Comment 2 Markus Elfring 2019-01-14 17:02:55 UTC
(In reply to Xisco Faulí from comment #1)
I suggest to take another look for the direct support of external data by the chart wizard.
Comment 3 Xisco Faulí 2019-01-17 11:05:24 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 4 Xisco Faulí 2019-06-27 16:58:55 UTC
This enhancement has been in UNCONFIRMED status for a while, moving it to NEW...

Note to the reporter: Changing the status to NEW doesn't mean the enhancement is going to be implemented. In order to do so, either you implement it yourself, you find someone to do it for you or you get professional support < https://www.libreoffice.org/get-help/professional-support/ >
Comment 5 Heiko Tietze 2019-08-19 09:19:36 UTC
Charts are created based on data in the spreadsheet. And there you can insert external data (https://wiki.documentfoundation.org/Faq/Calc/113).
Comment 6 Markus Elfring 2019-08-19 12:10:40 UTC
(In reply to Heiko Tietze from comment #5)
> Charts are created based on data in the spreadsheet. And there you can
> insert external data

I suggest to change this software limitation.
Comment 7 Heiko Tietze 2019-08-20 07:41:24 UTC
Eike, any chance to unleash the power of external data? I believe it makes not much sense and will be a source of confusion to have variable data in charts only but not in the spreadsheet.
Comment 8 Heiko Tietze 2019-08-27 07:19:38 UTC
*** Bug 121982 has been marked as a duplicate of this bug. ***
Comment 9 Thomas Lendo 2019-08-28 20:42:26 UTC
Setting back to Unconfirmed instead of Reopened until Eike is commenting.

See https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/REOPENED
Comment 10 Eike Rathke 2019-10-03 17:17:44 UTC
Actually that should already had worked. Taking.
Comment 11 Commit Notification 2019-10-03 20:37:54 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/354b29ace32b19a1b40e46612349b8d76f00c0c6

Resolves: tdf#122011 fix ValidExternal() check

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Eike Rathke 2019-10-03 20:38:34 UTC
Pending review https://gerrit.libreoffice.org/80168 for 6-3
Comment 13 Markus Elfring 2019-10-03 20:52:45 UTC
(In reply to Commit Notification from comment #11)
I am surprised that a tiny change for the condition check “… mnTab >= -1” should fix this software situation.

(In reply to Eike Rathke from comment #12)
Will the duplicate mark for the topic “Support for database items as data source in charts” (Bug 121982) be also reconsidered once more?
Comment 14 Eike Rathke 2019-10-04 10:07:34 UTC
(In reply to Markus Elfring from comment #13)
> I am surprised that a tiny change for the condition check “… mnTab >= -1”
> should fix this software situation.
Sometimes two tiny bits can make a huge difference..

> Will the duplicate mark for the topic “Support for database items as data
> source in charts” (Bug 121982) be also reconsidered once more?
Done.
Comment 15 Markus Elfring 2019-10-04 10:50:15 UTC
(In reply to Eike Rathke from comment #14)
Thanks for your constructive feedback.
I am curious if it will trigger any more desirable software improvements.
Comment 16 Commit Notification 2019-10-05 22:28:53 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/58367241f53ffca86c933f1cec506f05513b6a4f

Resolves: tdf#122011 fix ValidExternal() check

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Markus Elfring 2019-10-21 08:08:06 UTC
(In reply to Commit Notification from comment #16)
I have tried the provided functionality out again together with the software combination “LibreOffice Calc 6.3.3.1-861.1”.
Related software behaviour can be improved further then.

* I can copy an inappropriate test URL into the data range selection for the chart wizard.
  It can happen that I get notified by a modal message dialogue (without a title) about the non-existing path several times.
  I find the notification approach annoying then.

* I can copy also an acceptable test URL into the input field.
  I would appreciate further assistance in the selection for desired file names.