Bug Hunting Session
Bug 122012 - Extended graphical user interface for the specification of several cell areas
Summary: Extended graphical user interface for the specification of several cell areas
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 73226 (view as bug list)
Depends on:
Blocks: Chart-Enhancements
  Show dependency treegraph
 
Reported: 2018-12-10 14:39 UTC by Markus Elfring
Modified: 2019-08-28 20:47 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Elfring 2018-12-10 14:39:28 UTC
Build-ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb

The LibreOffice documentation contains the following information.

“…
If you want a data range of multiple cell areas that are not next to each other, enter the first range, then manually add a semicolon at the end of the text box, then enter the other ranges. Use a semicolon as delimiter between ranges.
…”


I imagine that it can become challenging (or even unsafe) to edit a growing list of cell areas in the text field “Data range”.

* Would you like to present a better overview for a detailed selection?

* How do you think about to extend the graphical user interface for this purpose?
Comment 1 Xisco Faulí 2019-01-14 16:10:10 UTC
Thanks for reporting this issue. It seems like a dupe of bug 53300

*** This bug has been marked as a duplicate of bug 53300 ***
Comment 2 Markus Elfring 2019-01-14 16:48:13 UTC
(In reply to Xisco Faulí from comment #1)
How do you think about safer graphical user interface adjustments (as suggested) since software difficulties were reported around an expand button on 2012-08-09?
Comment 3 Xisco Faulí 2019-01-17 11:05:20 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 4 Xisco Faulí 2019-06-27 13:47:01 UTC
Moving to NEW
Comment 5 Buovjaga 2019-08-18 10:59:22 UTC
(In reply to Markus Elfring from comment #0)
> * Would you like to present a better overview for a detailed selection?
> 
> * How do you think about to extend the graphical user interface for this
> purpose?

If you are unable to answer your own questions, we have to ask the design team.
Comment 6 Heiko Tietze 2019-08-19 09:32:12 UTC
A1;B2 is an invalid range. When you talk about how to specify cells in general (for example =SUM($A1:$B2;C4;X46) ), there is a colored feedback when you press F2 (edit). And we decided on a similar suggestion to color the parts of the formula as WORKSFORME (bug 124102). Or do you are talk about just the chart wizard?
Comment 7 Markus Elfring 2019-08-19 12:32:21 UTC
(In reply to Heiko Tietze from comment #6)
I came along usability concerns for the specification of distributed data ranges while fiddling with the chart wizard.
Further user interface extensions might become helpful also for other application areas.
Comment 8 Heiko Tietze 2019-08-20 07:34:31 UTC
Let's close this for now as duplicate of the issue the is WFM. If you have a concrete proposal feel free to reopen.

*** This bug has been marked as a duplicate of bug 124102 ***
Comment 9 Markus Elfring 2019-08-20 08:45:43 UTC
(In reply to Heiko Tietze from comment #8)
How do you think about to manage multiple cell areas by a list widget for data ranges?
Comment 10 Heiko Tietze 2019-08-20 08:55:51 UTC
(In reply to Markus Elfring from comment #9)
> (In reply to Heiko Tietze from comment #8)

As you are referring to c8, I closed the ticket as duplicate to the request of coloring the formula bar where we decided to not do it.

> How do you think about to manage multiple cell areas by a list widget for
> data ranges?

I cannot follow you, "multiple cells" might be a data range or not, which in turn is activated per list, yes.
Comment 11 Markus Elfring 2019-08-20 13:42:53 UTC
(In reply to Heiko Tietze from comment #10)
> I cannot follow you, "multiple cells" might be a data range or not, which in
> turn is activated per list, yes.

Can you imagine that a short input field can become insufficient for editing a growing list of cell areas in the text field “Data range”?

* Would you be looking for a bigger text input area?

* Will a list (or table) widget be occasionally safer for the management of entries (instead of separation by semicolons)?
Comment 12 Thomas Lendo 2019-08-21 07:44:36 UTC
I ignore these questions over questions and focus on the core of the issue: It's possible to define more than one region in a spreadsheet in the chart data ranges dialogs as described in the help. But this is only possible 'by hand' using a semicolon. It's not possible in the GUI with a button.

Suggestion:
Adding a + and - button at the right end of the text field.

When clicking on + then a new row with a next text field will be showed where the user can define a new region. There is also a + and - button.

Clicking at one of these + adds a new text field directly below.

Clicking at one of these - deletes this whole text field row; if only the first text field exists then only the defined range will be deleted (the text field will be emptied).
Comment 13 Heiko Tietze 2019-08-22 12:39:33 UTC
We had this topic on the agenda of the weekly design meeting. Adding buttons would be effective at all cases with multi-selections not only charts. It wouldnt be clear how these +/- buttons work, in particular what is removed. And since manual editing is common I recommend again to close this ticket as WFM.
Comment 14 Markus Elfring 2019-08-22 12:56:39 UTC
(In reply to Heiko Tietze from comment #13)
I hope that the corresponding user interface can be improved further.
Comment 15 Thomas Lendo 2019-08-22 21:29:56 UTC
(In reply to Heiko Tietze from comment #13)
> We had this topic on the agenda of the weekly design meeting. Adding buttons
> would be effective at all cases with multi-selections not only charts. It
> wouldnt be clear how these +/- buttons work, in particular what is removed.
> And since manual editing is common I recommend again to close this ticket as
> WFM.
I don't believe that it's so unclear. Tooltips will also help. I don't remember a similar implementation in another UI element but in the custom file properties dialog.
Comment 16 Thomas Lendo 2019-08-28 20:46:14 UTC
*** Bug 73226 has been marked as a duplicate of this bug. ***
Comment 17 Thomas Lendo 2019-08-28 20:47:46 UTC
As this is not only a new request, if anybody has new info or ideas to share, please reopen as Unconfirmed.