Download it now!
Bug 124102 - Display components of formula without edit
Summary: Display components of formula without edit
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Formula
  Show dependency treegraph
 
Reported: 2019-03-15 16:26 UTC by pentike
Modified: 2019-08-20 07:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
marking of formula components (14.68 KB, image/png)
2019-03-15 16:26 UTC, pentike
Details
Current highlighting (4.72 KB, image/png)
2019-04-18 08:16 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pentike 2019-03-15 16:26:58 UTC
Created attachment 150004 [details]
marking of formula components

I would like to have a toggle button which enables the display of formula components without editing a cell.

This would greatly help navigating in a sheet with many calculations that are based upon each other.

See the attached image for a basic visualization.
Comment 1 Heiko Tietze 2019-04-17 11:10:53 UTC
Where do these colors come from? Picked up from what the user defined as cell background (and if so, why not the font color itself) or taken from some predefined list and applied as cell background only while in formula edit mode?
Comment 2 Eike Rathke 2019-04-17 14:23:12 UTC
The attachment is a mockup illustrating a wish. There's no such functionality that changes cell backgrounds. What we have while entering edit mode is coloured cell borders corresponding to formula references. The list of colours is hard coded.

I don't see much benefit though in implementing yet another button for what can be achieved by simply pressing F2 and when done viewing pressing Esc.

To visualize more complicated dependencies there's Tools -> Detective.
Comment 3 Heiko Tietze 2019-04-18 08:16:45 UTC
Created attachment 150844 [details]
Current highlighting

My question was meant for the OP ;-). But thanks for your input, I add a screenshot with this feature.
Comment 4 Cor Nouws 2019-04-24 12:45:39 UTC
(In reply to Eike Rathke from comment #2)
> The attachment is a mockup illustrating a wish. There's no such
> functionality that changes cell backgrounds. What we have while entering
> edit mode is coloured cell borders corresponding to formula references. The
> list of colours is hard coded.
> 
> I don't see much benefit though in implementing yet another button for what
> can be achieved by simply pressing F2 and when done viewing pressing Esc.
Indeed, because for the proposed functionality it is still needed to select a cell.
Then a problem in "a sheet with many calculations that are based upon each other" will be that there are many cells with colors, that have to be different and the number will make it hard to find what you are looking for.
  >> WFM
Comment 5 pentike 2019-04-24 13:26:33 UTC
I was not aware of the Tools->Detective so I tried it out and liked it very much.

However this too lacks the immediate feedback but is a good building ground for this functionality. I would suggest to extend the Detective with "cell" switch. If turned on, it would show the dependents and precendents of the currently selected cell, so the user can navigate around the table only focusing on one cell at a time.

It may even color the lines matched with the cells in the formula row, but it would be useful even without coloring.
Comment 6 Cor Nouws 2019-04-24 13:43:10 UTC
(In reply to pentike from comment #5)
> I was not aware of the Tools->Detective so I tried it out and liked it very
> much.
Did you try hard enough?

> However this too lacks the immediate feedback but is a good building ground
> for this functionality. I would suggest to extend the Detective with "cell"
> switch. If turned on, it would show the dependents and precendents of the
> currently selected cell, so the user can navigate around the table only
> focusing on one cell at a time.
I does show for the cell with focus already..
You can use it in combination with F2 too..
Comment 7 pentike 2019-04-24 14:18:03 UTC
Yes, it shows for the cell in focus, but if I move the focus to another cell, I have to select Detective again.

My point is that I would like to see the calculated value of a cell and the dependencies at once while navigating in the table without having to select menu items or press keys on each cell.
Comment 8 Heiko Tietze 2019-04-25 12:53:51 UTC
We discussed the enhancement idea in the design meeting. As commented here we do have some support that is sufficient. It's also not perfectly clear where the support comes from and how it's applied. So we think the formula editing is okay as it is. => WFM
Comment 9 Heiko Tietze 2019-08-20 07:34:31 UTC
*** Bug 122012 has been marked as a duplicate of this bug. ***