Bug 122029 - Crash in: s_stub_releaseInterface
Summary: Crash in: s_stub_releaseInterface
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2018-12-11 19:29 UTC by noriegap
Modified: 2019-05-09 22:15 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["s_stub_releaseInterface"]

Test file (18.13 KB, application/vnd.oasis.opendocument.text)
2019-01-05 12:06 UTC, Alan Grunwald
Database referred to in previous comment (1.73 MB, application/x-sqlite3)
2019-01-11 22:57 UTC, Alan Grunwald

Note You need to log in before you can comment on or make changes to this bug.
Description noriegap 2018-12-11 19:29:56 UTC
This bug was filed from the crash reporting server and is br-e96f84ea-fed2-442f-98a7-54179efe4ea4.
Comment 1 Xisco Faulí 2018-12-12 11:32:59 UTC
Thank you for reporting the bug.
Unfortunately without clear steps to reproduce it, we cannot track down the origin of the problem.
Please provide a clearer set of step-by-step instructions on how to reproduce the problem.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the steps are provided
Comment 2 Alan Grunwald 2019-01-05 12:06:42 UTC
Created attachment 148063 [details]
Test file

LO Writer froze when I attempted to add a modification date field in the footer. The program hangs as soon as I select Insert > Field > More Fields and has to be stopped using the Windows Task Manager. As far as I could tell, Writer seems to be in a fairly tight loop as it was not page faulting nor was it doing any IO (there were some page faults when the hang first happened but nothing after a second or two).

The failure is absolutely hard and occurs each time I attempt to add the field.

I notice that a similar failure occurs if I try to add a cross-reference - I've only tried once. I have several other files that trigger similar failures when trying to add a cross-reference. They are much bigger and already contain several cross-references. With these files, I can add cross-refs using LO Writer on Linux Mint. I haven't (yet) tried that with this file, nor do I recall off-hand any details of my Mint installation or of the LO version I have there.
Comment 3 Aron Budea 2019-01-06 05:00:07 UTC
Do you have any registered databases? (apart from the default Bibliography) If you do, does the crash persist if you remove them?
Comment 4 Alan Grunwald 2019-01-11 21:08:44 UTC
What is a registered database? I don't knowingly have any.

(Sorry to have left response for so long.)
Comment 5 Alan Grunwald 2019-01-11 21:14:45 UTC
To confirm that I was able to add the modification filed using my Mint version and that my Windows version happily displayed the contents of the field once the file was transferred there.

I'm sat at my Windows machine now and still haven't noted details of the Mint machine. Let me know if you need them.
Comment 6 Aron Budea 2019-01-11 22:27:51 UTC
(In reply to Alan Grunwald from comment #4)
> What is a registered database? I don't knowingly have any.
> (Sorry to have left response for so long.)
Ah, my bad, I forgot to reply to your e-mail here. Open Tools -> Options..., LibreOffice Base -> Datbases. There's a default one, Bibliography, I'm interested if whether anything else is there.

No specific ideas so far, but there've been a few crashes with combination of fields + mail-merge data sources (which would also appear in that list).
Comment 7 Alan Grunwald 2019-01-11 22:50:05 UTC
Ahh. Interesting.

I did have a couple of databases listed there. I deleted them both and now I can insert references to my heart's content without any problems.


I just registered the (soon to be) attached database file with Tools > Options ... LibreOffice Base>Databases ... New and the failure returned. I delete/unregistered it again and all is well.

That's me well satisfied, thank you. I hope you're able to track down and fix the underlying cause.
Comment 8 Alan Grunwald 2019-01-11 22:57:40 UTC
Created attachment 148247 [details]
Database referred to in previous comment

(Sorry; was I able to attach the file to the comment? I wasn't really watching. D'oh!)

I had this db on the desktop. When I registered it the failure returned; when I deregistered it the failure went away again.

I don't recall where the db came from; I have a similarly named .mdb file that I do recall downloading, but don't know how I converted it to .db.
(I'm pretty sure the original _was_ an Access database; this version certainly seems to be an sqlite db. I really do wish I could remember how I converted it. Really, really, really :-)
Comment 9 Robert Großkopf 2019-01-12 09:54:13 UTC
Could be the same reason - all registered databases will be opened when inserting cross-references: bug 119610.
Comment 10 Dieter 2019-05-09 09:10:16 UTC
Alan, there is no crash report with this signature in LO and So can you try it with one of this versions?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build or to RESOLVED WORKSFORME, if the problem went away.
Comment 11 Alan Grunwald 2019-05-09 17:25:08 UTC
Dieter - I have been OK ever since Jan-11 (my comment 8 above).

Do I need to do something to keep bugzilla happy?
Comment 12 Dieter 2019-05-09 20:16:19 UTC
(In reply to Alan Grunwald from comment #11)
> Do I need to do something to keep bugzilla happy?

Yes, change status to RESOLVED WORKSFORME (I did it).
Comment 13 Alan Grunwald 2019-05-09 22:15:24 UTC
OK, sorry.

I now know, if there is a next time. Thank you.