Bug 119610 - Insert > Cross-reference: All registered databases are opened
Summary: Insert > Cross-reference: All registered databases are opened
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All All
: high major
Assignee: Justin L
URL:
Whiteboard: target:7.2.0 target:7.1.1 target:7.0.5
Keywords: bibisected, bisected, regression
: 119419 (view as bug list)
Depends on:
Blocks: Fields-Dialog
  Show dependency treegraph
 
Reported: 2018-08-30 14:23 UTC by Robert Großkopf
Modified: 2021-02-24 01:49 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Register the database. Then try Insert > Crossreference (10.89 KB, application/vnd.oasis.opendocument.database)
2018-09-03 19:00 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2018-08-30 14:23:18 UTC
Following bug appears in every Writer-document if you have registered databases:

Create a new Writer-document
Go to Insert > Cross-reference
Dialog for input password for every external database with password-protection will appear.
Also migration-dialog for migrating internal HSQLDB to internal Firebird-database will appear when internal features are set to experimental. See bug 119210 for this.

Seems Writer connects to databases, because there is a folder "database" in the dialog "fields". This connection happens in LO 5.* (and all earlier versions) when one database should be opened, not when the dialog "fields" will be opened. Why should there be a connection to all the databases if you won't need any?

This bug doesn't appear in LO 5.4.6.2, first appears in LO 6.0.0.1 here. I haven't installed any version between this two.
My system: OpenSUSE 15, 64bit rpm Linux
Comment 1 Robert Großkopf 2018-08-30 14:31:04 UTC
My opinion: This is a duplicate of bug 119210, but I can't convince the reporters and QA. This bug appears first with LO 6.0, not with the migration-dialog. The migration-dialog (HSQLDB → Firbird) shows the buggy behaviour as well as every other external database. Internal databases couldn't show this, because nobody knows Writer is connecting to the databases.
Comment 2 Alex Thurgood 2018-08-30 14:39:55 UTC
Confirmed with 

Version: 6.0.5.2
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
Threads CPU : 8; OS : Mac OS X 10.13.6; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 3 Alex Thurgood 2018-08-30 14:41:33 UTC
Not reproducible in 

Version: 5.4.7.2
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
Threads CPU : 8; OS : Mac OS X 10.13.6; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 4 Xisco Faulí 2018-09-03 17:47:51 UTC
Hi Robert,
Could you please attach a sample document password protected ?
Comment 5 Robert Großkopf 2018-09-03 18:58:30 UTC
(In reply to Xisco Faulí from comment #4)
> Hi Robert,
> Could you please attach a sample document password protected ?

Hi Xisco,

you must have a registered database which needs a password. I have tested this with a registered MariaDB on my server. So it could be bibisected only by someone, who has a registered database, which needs a password.

I will attach an *.odb-file for a registered database. Will hope it will ask for a password without any existing database behind.
Comment 6 Robert Großkopf 2018-09-03 19:00:15 UTC
Created attachment 144643 [details]
Register the database. Then try Insert > Crossreference
Comment 7 Aron Budea 2018-09-06 06:27:39 UTC
Bibisected to the following commit using repo bibisect-win32-6.0. Adding Cc: to Szymon Kłos.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=75a881829f19439245cdb859fc16d59461992f79
author		Szymon Kłos <szymon.klos@collabora.com>	2017-10-04 20:53:27 +0200
committer	Szymon Kłos <szymon.klos@collabora.com>	2017-10-05 08:14:01 +0200

tdf#112634 avoid crash
Comment 8 Alex Thurgood 2018-11-22 07:56:06 UTC
*** Bug 121606 has been marked as a duplicate of this bug. ***
Comment 9 Cor Nouws 2018-11-22 08:59:10 UTC
(In reply to Alex Thurgood from comment #8)
> *** Bug 121606 has been marked as a duplicate of this bug. ***

possibly..
Comment 10 Justin L 2021-01-13 12:48:21 UTC
I wonder why this wasn't just reverted. It looks to me like the initial reason given in bug 112634 was just to clean-up a defunct entry (eg. "sample list"). If it causes this kind of trouble, why not just get rid of it?
Comment 11 Justin L 2021-01-14 09:43:28 UTC
So this dbtree's InitTreeList is used by at least these areas:
1.) Edit - Exchange Databases.
2.) Insert - Field.


It is NOT used by
A.) Options - Base - Databases
B.) Tools - Mailmerge - Select Address List
C.) View - Data Sources

During the mailmerge, the example file that the other bug was using (sample list.ods) is registered as a database, so I'm not sure why they considered it to be a defunct entry.

A proposed fix is at https://gerrit.libreoffice.org/c/core/+/109242
Comment 12 Commit Notification 2021-01-16 07:38:09 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/647c9de0338350c1b5eff4b9adf08bd06930e36b

tdf#119610 tdf#112634: Don't show broken connections - RevB

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Justin L 2021-01-16 09:48:34 UTC
*** Bug 119419 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2021-01-19 10:46:37 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/6c580008d397f5f5f4a0bfd879308018b5d2a54f

tdf#119610 tdf#112634: Don't show broken connections - RevB

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2021-01-20 11:18:30 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/ebdf896c9d3260b544ebe67ffa09d21be603d170

tdf#119610 tdf#112634: Don't show broken connections - RevB

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.