Download it now!
Bug 121606 - prompt for password pops up of protected spreadsheet-datasource, as soon as file with related databasefields is opened
Summary: prompt for password pops up of protected spreadsheet-datasource, as soon as f...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Database-Import
  Show dependency treegraph
 
Reported: 2018-11-21 20:56 UTC by Cor Nouws
Modified: 2019-01-13 18:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
zip file with the three needed files (29.56 KB, application/zip)
2018-11-21 20:56 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2018-11-21 20:56:46 UTC
Created attachment 146893 [details]
zip file with the three needed files

I'll attach
 a. a spreadsheet protected with PW Test1234
 b. a database file with that spreadsheet
 c. a file with fields from that data source

1. place a and b in same location
2. add b as data source (Tools > Options etc )
3. open c. 
  > prompt for password pops up immediately
One would expect that to happen only when data source window is opened?

Esc. doesn't help... Pop-up comes up again and again.

Noticed in (but prolly earlier) Versie: 6.2.0.0.alpha1+
Build ID: b8e260a9372de9ee1186e1f78ade29717e9b8026
CPU-threads: 4; Besturingssysteem: Linux 4.15; UI-render: standaard; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-10-29_17:17:42
Locale: nl-NL (nl_NL.UTF-8); Calc: threaded
Comment 1 Alex Thurgood 2018-11-22 07:56:06 UTC

*** This bug has been marked as a duplicate of bug 119610 ***
Comment 2 Lionel Elie Mamane 2018-11-22 09:09:12 UTC
Since c has fields from the data source, to populate these fields, the data source has to be opened, and thus the password given. So I don't understand why you consider this a bug.
Comment 3 Cor Nouws 2018-11-22 09:32:55 UTC
(In reply to Lionel Elie Mamane from comment #2)
> Since c has fields from the data source, to populate these fields, the data
> source has to be opened, and thus the password given. So I don't understand
> why you consider this a bug.

I would expect to be prompted for the password when I open the datasource.
Not when I open a file that has a field from a datasource. Often I don't want to change the fields (default) content.
Comment 4 Xisco Faulí 2018-11-26 18:34:37 UTC
Actually this was the expected behaviour until recently.

Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5c2c5ff01c23e4f7a8947746afc13a46cbef5bec

author	Mike Kaganski <mike.kaganski@collabora.com>	2018-05-21 09:35:01 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2018-05-23 11:38:50 +0200
commit	5c2c5ff01c23e4f7a8947746afc13a46cbef5bec (patch)
tree	2b7304c9563ac33fdda18b80131cc85114cecc45
parent	1464b94ab8ef58b2620e05d663403684deb19d0c (diff)
tdf#115386: Show Mail Merge toolbar for documents with MM fields

Bisected with: bibisect-linux64-6.1

Adding Cc: to Mike Kaganski

I assume as we're showing the toolbar, it asks for the password as we were showing the datasources
Comment 5 Mike Kaganski 2018-12-06 20:47:54 UTC
https://gerrit.libreoffice.org/64738
Comment 6 Commit Notification 2018-12-07 04:52:46 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/60714a814847f6d10f00aa6809a3896a48741e0b%5E%21

tdf#121606: displaying Mail Merge toolbar shouldn't activate connection

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-12-10 10:11:13 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/b27a9058c706d70adddc71544b74b1f9607185bb%5E%21

tdf#121606: displaying Mail Merge toolbar shouldn't activate connection

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-12-11 12:04:56 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 0ad2302cf6787cacbbaca081a890a0e356a55297
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Mike Kaganski, thanks for fixing this!!

Cherry-picked to libreoffice-6-1 -> https://gerrit.libreoffice.org/#/c/64959/

btw, I found I crash while testing it not related to the commit. I'll create a new  report for it...
Comment 9 Commit Notification 2018-12-11 23:47:32 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/1ae5f5274011e42dfa85dca5f472ff8bbeecaa4e%5E%21

tdf#121606: displaying Mail Merge toolbar shouldn't activate connection

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Cor Nouws 2019-01-13 18:07:13 UTC
works nice now indeed. Thanks Mike!