Bug 122030 - Table Toolbar constant placing is now impossible
Summary: Table Toolbar constant placing is now impossible
Status: RESOLVED DUPLICATE of bug 36976
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Writer-Toolbars
  Show dependency treegraph
 
Reported: 2018-12-12 01:12 UTC by Joel Choi
Modified: 2020-06-04 12:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Choi 2018-12-12 01:12:24 UTC
Description:
Manually opened Table Toolbar automatically turned off.

Steps to Reproduce:
1.Manually place Table Toolbar by selecting it from View - Toolbars - Table.
2.Place cursor inside table then move outside table.
3.Table Toolbar turned off automatically.

Actual Results:
Table Toolbar turned off automatically.

Expected Results:
Table Toolbar should kept opend if user placed it manually.


Reproducible: Always


User Profile Reset: No



Additional Info:
Many of Writer document composed of text and tables. Automatic opening and disappearing of Table Toolbar makes me loose focus on work.
Comment 1 Dieter 2018-12-12 08:02:44 UTC
I confirm it with

Version: 6.2.0.0.beta1 (x64)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded

and

Version: 6.1.3.2 (x64)
Build-ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded

and

Version: 5.4.7.2 (x64)
Build-ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU-Threads: 4; BS: Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: CL
Comment 2 Dieter 2020-05-20 19:28:10 UTC
Still reproducible with

Version: 7.0.0.0.alpha1+ (x64)
Build ID: 4804d969bacd25ad586b3bf70d3dc8c27adb48ef
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: en-GB (de_DE); UI: en-GB
Calc: threaded

but I'm not sure anymore about the expected result

cc: Design-Team for further input and decision
Comment 3 Heiko Tietze 2020-06-04 12:59:26 UTC
The sticky toolbars are requested frequently. The issue is not only relevant at tables but also shapes, lists, images etc.

bug 36976: Add option to disable the automatic popping up of toolbars 
bug 38850: UI: Bullets and Numbering toolbar disappears. Allow make it persistent 

Taking the first as prototype.

As a workaround you may pick one of the alternative UIs (aka Notebookbar), see View > User Interface > *

*** This bug has been marked as a duplicate of bug 36976 ***