Download it now!
Bug 122077 - LibreOffice writer_pdf_Exporter shrinks output layout
Summary: LibreOffice writer_pdf_Exporter shrinks output layout
Status: RESOLVED DUPLICATE of bug 124325
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2018-12-13 14:05 UTC by heiko.thierbach
Modified: 2019-10-16 14:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Original PDF formular (871.60 KB, application/pdf)
2018-12-13 14:07 UTC, heiko.thierbach
Details
Converted PDF (341.17 KB, application/pdf)
2018-12-13 14:07 UTC, heiko.thierbach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description heiko.thierbach 2018-12-13 14:05:04 UTC
Description:
When using writer_pdf_Export (CLI or provided python)tzhe concerted PDF layout is shrinked down by approx. 5% and does not fit the original document anymore. 
 
For some legal reasons the original file and the PDF must look like exactly the same.

Steps to Reproduce:
1.open s shell (Mac or Linux)
2.execute "soffice --headless --convert-to pdf:writer_pdf_Export somefile"
3.compare the source file and the converted FDP

Actual Results:
The converted layout is shrinked down.

Expected Results:
Layout of source and converted PDF should be the same.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 4; OS: Mac OS X 10.14.1; UI render: default; 
Locale: de-DE (de_DE.UTF-8); Calc: group threaded

Renderer: Intel Iris OpenGL Engine
Vendor: Intel Inc.
Memory: 1536 MB
Version: 4.1 INTEL-12.2.17
Device: MacBookPro11,1
Shading language version: 4.10


Max texture size: 16384 x 16384
Max vertex texture image units: 16
Max texture image units: 16
Max geometry texture units: 16
Max anisotropic filtering value: 16
Max viewport size: 16384 x 16384
Max Clip Distances: 8
Max samples: 8


Extensions: 45


GL_ARB_tessellation_shader
GL_APPLE_texture_range
GL_EXT_framebuffer_multisample_blit_scaled
GL_ARB_viewport_array
GL_ARB_gpu_shader_fp64
GL_ARB_explicit_attrib_location
GL_NV_texture_barrier
GL_ARB_separate_shader_objects
GL_ARB_texture_storage
GL_ARB_gpu_shader5
GL_ARB_texture_swizzle
GL_EXT_texture_compression_s3tc
GL_ARB_texture_cube_map_array
GL_ARB_blend_func_extended
GL_ARB_vertex_attrib_64bit
GL_EXT_texture_sRGB_decode
GL_ARB_texture_gather
GL_EXT_texture_filter_anisotropic
GL_APPLE_row_bytes
GL_ARB_transform_feedback2
GL_ARB_transform_feedback3
GL_ARB_draw_indirect
GL_ARB_texture_query_lod
GL_ARB_draw_buffers_blend
GL_ARB_sample_shading
GL_ARB_internalformat_query
GL_ARB_timer_query
GL_ARB_shader_subroutine
GL_ATI_texture_mirror_once
GL_EXT_debug_marker
GL_APPLE_rgb_422
GL_ARB_vertex_type_2_10_10_10_rev
GL_EXT_debug_label
GL_ARB_texture_buffer_object_rgb32
GL_ARB_instanced_arrays
GL_APPLE_container_object_shareable
GL_ARB_ES2_compatibility
GL_APPLE_client_storage
GL_ARB_sampler_objects
GL_ARB_occlusion_query2
GL_ARB_shading_language_include
GL_ARB_texture_rgb10_a2ui
GL_APPLE_object_purgeable
GL_ARB_shader_bit_encoding
GL_APPLE_flush_render
Core features

v3.0 (100 % - 23/23)
v3.1 (100 % - 8/8)
v3.2 (100 % - 10/10)
v3.3 (100 % - 10/10)
v4.0 (100 % - 14/14)
v4.1 (100 % - 7/7)
v4.2 (15 % - 2/13)
v4.3 (0 % - 0/23)
v4.4 (0 % - 0/10)
v4.5 (0 % - 0/11)
v4.6 (0 % - 0/11)
vARB 2015 (0 % - 0/12)
OpenGL driver version check (Current: 4.1 INTEL-12.2.17, Latest known: ):
Latest version of display drivers found
According the database, you are running the latest display drivers for your video card.
Extension verification:
Comment 1 heiko.thierbach 2018-12-13 14:07:06 UTC
Created attachment 147500 [details]
Original PDF formular
Comment 2 heiko.thierbach 2018-12-13 14:07:46 UTC
Created attachment 147501 [details]
Converted PDF
Comment 3 Timur 2018-12-14 17:38:49 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2019-01-22 16:36:20 UTC Comment hidden (obsolete)
Comment 5 heiko.thierbach 2019-01-27 12:48:18 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2019-02-07 20:15:02 UTC
(In reply to heiko.thierbach from comment #5)
> Please refer to the already attached documents

Please, attached the original file, not the pdf output...
Comment 7 heiko.thierbach 2019-02-08 11:25:54 UTC
We try to convert a non PDF/A-1a document into a PDF/A-1a format.

Therefore the Original_PDF_fomular IS the source/input file!
Comment 8 Xisco Faulí 2019-03-21 10:45:37 UTC
Checking both attachments, I don't see any layout difference at first glance.
Could you please indicate where the problem is ?
Comment 9 Alex Thurgood 2019-03-28 14:36:10 UTC
Both documents attached appear to have identical point size. The Converted PDF is in PDF 1.4 format, whereas the original is in PDF 1.7 format.

Apart from that, like Xisco, I can't see any difference in screen size display when opening both documents in Apple Preview.

A printout of both documents results in identical positioning of the various form elements and text, as verified by manually superposing printed pages over each
Comment 10 QA Administrators 2019-09-25 03:01:49 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2019-10-16 14:45:40 UTC
Closing as a duplicate of bug 124325

*** This bug has been marked as a duplicate of bug 124325 ***