Bug 122097 - FILEOPEN XLSX, Conditional formatting not working the same in LO as in MSO
Summary: FILEOPEN XLSX, Conditional formatting not working the same in LO as in MSO
Status: RESOLVED DUPLICATE of bug 122094
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX-Conditional-Formatting
  Show dependency treegraph
 
Reported: 2018-12-14 11:55 UTC by NISZ LibreOffice Team
Modified: 2020-12-18 11:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The original file. (18.03 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-12-14 11:56 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc. (381.91 KB, image/png)
2018-12-14 11:57 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-12-14 11:55:35 UTC
Description:
Conditional formatting with condition of greater than a number is not working the same for cells with text and – symbol when opened in LO.

Steps to Reproduce:
    1. Create a new xlsx in Excel.
    2. Create a new conditional formatting rule with greater than a number condition.
    3. Write some numbers and some texts in the cells in the range, also some - symbols
    4. Save it and open it in LO
    5. Notice the differences.

Actual Results:
Only the  numbers that are greater than the given number are formatted in LO while in MSO the text and the – symbol is formatted as well.

Expected Results:
Expected results: It should be formatted the same as in MSO.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-12-14 11:56:31 UTC
Created attachment 147529 [details]
The original file.
Comment 2 NISZ LibreOffice Team 2018-12-14 11:57:01 UTC
Created attachment 147530 [details]
Screenshot of the original document side by side in Excel and Calc.
Comment 3 Roman Kuznetsov 2018-12-15 08:11:34 UTC
confirmed different behaviour between Excel and Calc in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

but I'm not sure that in Excel made right. 
IMHO Calc absolutely right work with the condition in this case.
Comment 4 Xisco Faulí 2018-12-18 13:51:39 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 5 Gabor Kelemen (allotropia) 2019-07-19 07:30:21 UTC
This is probably a duplicate to bug #122094 - text is not formatted like numbers are.
Comment 6 NISZ LibreOffice Team 2020-12-18 11:24:03 UTC
This contains the condition "cell value > 300" just like the bug #122094 contains "cell value > 0".
These are then not applied to text, only numbers in Calc. 
Frankly, this makes sense. Considering "test" greater than 0 or 300 does not.

*** This bug has been marked as a duplicate of bug 122094 ***