Bug Hunting Session
Bug 122099 - Overlap of signs in formel editor in libreoffice writer win7.
Summary: Overlap of signs in formel editor in libreoffice writer win7.
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 122125 (view as bug list)
Depends on:
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2018-12-14 12:04 UTC by patrick.hinz
Modified: 2018-12-28 11:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
picture of the bug (176.52 KB, image/png)
2018-12-14 12:13 UTC, patrick.hinz
Details
Example ODT with Math formula (10.49 KB, application/vnd.oasis.opendocument.text)
2018-12-16 19:22 UTC, Roman Kuznetsov
Details
Screenshot with bug (14.42 KB, image/png)
2018-12-16 19:24 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description patrick.hinz 2018-12-14 12:04:15 UTC
Description:
I have a frequently but randomly appearing bug which does what the titels says. It's sometimes getting removed if I add random signs and erase them again but otheritmes I have to make a new formular. I had this problem also with an older version of libreoffice. Do you know how to fix it or can you fix it officialy?
If you save and restart the document it still around.
I am working on win7 on bootcamp 64bit, Libre office Version: 6.1.3.2 (x64)
 

Steps to Reproduce:
1.Write a formular with equal signes, fractions and index signs
2.Maybe it appears
3.

Actual Results:
It appears randomly as discribed.

Expected Results:
It appears.


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Showed all signs correct
Comment 1 patrick.hinz 2018-12-14 12:13:11 UTC
Created attachment 147537 [details]
picture of the bug

picture of the bug.
Comment 2 Durgapriyanka 2018-12-14 17:17:28 UTC
Thank you for reporting the bug. I can not reproduce the bug in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 patrick.hinz 2018-12-15 14:52:40 UTC
Thankyou for trying. Where did you get 6.3 ? I can't find it on the libreoffice website.
Comment 4 raal 2018-12-16 08:23:15 UTC
(In reply to patrick.hinz from comment #3)
> Thankyou for trying. Where did you get 6.3 ? I can't find it on the
> libreoffice website.

You can download it from here:
http://dev-builds.libreoffice.org/daily/master/
Comment 5 Roman Kuznetsov 2018-12-16 19:22:21 UTC
I can repro it in

Версия: 6.1.3.1 (x64)
ID сборки: a9670562c26181ec3afbe381c9ff499ae88c98b7
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; 
Локаль: ru-RU (ru_RU); Calc: threaded

and in

Версия: 6.2.0.0.beta1 (x64)
ID сборки: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: CL

Version: 6.3.0.0.alpha0+ (x64)
Build ID: a04e615e1f9371401946c7c89d7ec439ce92cfec
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-05_06:42:22
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

with my example (see attach)

Status of OpenGL doesn't matter
Comment 6 Roman Kuznetsov 2018-12-16 19:22:53 UTC
Created attachment 147612 [details]
Example ODT with Math formula
Comment 7 Roman Kuznetsov 2018-12-16 19:24:00 UTC
Created attachment 147613 [details]
Screenshot with bug
Comment 8 Dieter Praas 2018-12-17 08:34:48 UTC
*** Bug 122125 has been marked as a duplicate of this bug. ***
Comment 9 patrick.hinz 2018-12-17 13:07:01 UTC
For temporarly erasing the effects of the bug, type = at the end of the line and erase it again. There has to be no space between the last part of the formular and the =.
Comment 10 Xisco Faulí 2018-12-18 16:34:07 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

doubleclicking on it fixes the issue...
Comment 11 Hermann Rochholz 2018-12-28 11:35:38 UTC
NO: 
I tried to write with my class formulae and it did NOT vanish when re-opening. It was a full desaster. 

But it was an older LO version (6.1.???) - have to check in school. Win10.
Also closing and opening document did NOT help. 

It was really strange: 
ALL 15(!) or nearly all pupils had these problems.
15 Children complaining at once. 
All the formulae were in the mid of document. 
Headline:
"Objects" and below: "How to write a formula". 

I tried in the document - NO way. E.G. a square root became 10cm in height.
(It was an "example" - check out).  It was not only overlapping. 

After that disastrous hour I logged in with my DummyUser account- typing formula- everything perfect! No way to reproduce. This was at the same computer where I had before these huge problems where I tried to fix the problem in the document of this 16 year old pupil and I failed.