Download it now!
Bug 122171 - LibreOffice remains open in background if it's closed while XML filter settings dialog is open
Summary: LibreOffice remains open in background if it's closed while XML filter settin...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.5
Keywords: difficultyBeginner, easyHack, skillCpp, topicDebug, topicUI
Depends on:
Blocks:
 
Reported: 2018-12-18 11:27 UTC by Xisco Faulí
Modified: 2019-01-08 10:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-12-18 11:27:20 UTC
This is a follow-up bug of bug 122153 and can only be reproduced after https://git.libreoffice.org/core/+/cabc14a343142e53ab1ef0085b023bb7fadcf449%5E%21

Steps to reproduce:
1. Open attachment 147617 [details]
2. Edit the form
3. Tools - XML filter settings
4. Click on New or Edit
5. Close LibreOffice
6. Close the XML filter settings dialog
-> LibreOffice seems to be closed but it remains open in background...

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 6dc36d343aeacb3d1e14ec0c847937d63f4e68a7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Caolán McNamara 2018-12-18 17:28:06 UTC
I think bug#102288 causes this problem. This dialog throws a CloseVeto when it has a modal dialog open, but that no longer does what it used to do, which was to leave a toplevel window open.
Comment 2 m.a.riosv 2018-12-18 22:17:29 UTC
Repro
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 7176211382cc288750273e16ea7eb206854be33f
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-17_03:47:50
Locale: es-ES (es_ES); UI-Language: en-US
Calc: threaded
Comment 3 Samuel Mehrbrodt (CIB) 2018-12-19 08:56:28 UTC
(In reply to Caolán McNamara from comment #1)
> I think bug#102288 causes this problem. This dialog throws a CloseVeto when
> it has a modal dialog open, but that no longer does what it used to do,
> which was to leave a toplevel window open.

Yes this seems to be caused by my change how TerminationVetoException is handled.
So instead of throwing a TerminationVetoException, we need to throw a CloseVetoException here (that would prevent windows from closing).

And we need to listen to XCloseListener::queryClosing instead of XTerminateListener::queryTermination.

The file is filter/source/xsltdialog/xmlfilterdialogcomponent.cxx .

This change should be quite easy, making an Easy Hack out of it.
Comment 4 Commit Notification 2018-12-19 14:17:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/422b12bc13b34f4e99f79b2571b89296873ebe89%5E%21

tdf#122171 block closing final window while xslt filter dialog is modal

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2018-12-19 16:31:02 UTC
indeed, that seems to work, thanks for the hint.

backports to 6-2 and 6-1 in gerrit
Comment 6 Commit Notification 2018-12-19 20:14:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/660f1b6b20a9d22f840d0e723d110c2cf8f77fb4%5E%21

tdf#122171 block closing final window while xslt filter dialog is modal

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2018-12-21 17:56:16 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 7d63c700c36afd27850346e42b92768f084f5d4d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded


@Caolán, Thanks for fixing this!!
Comment 8 Commit Notification 2019-01-08 10:10:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/55f3a2d1d44751be38d6e374cc2291f97cae63a2%5E%21

tdf#122171 block closing final window while xslt filter dialog is modal

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.