Bug Hunting Session
Bug 122172 - OOoSpotlightImporter causes mdworker to crash repeatedly.
Summary: OOoSpotlightImporter causes mdworker to crash repeatedly.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Mac OS X (All)
: high major
Assignee: Tomaz Vajngerl
URL: https://www.ghdsports.net/
Whiteboard: target:6.3.0 target:6.2.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-12-18 11:39 UTC by Alex Thurgood
Modified: 2019-09-04 11:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash backtrace provided by Apple (53.31 KB, text/plain)
2018-12-18 11:42 UTC, Alex Thurgood
Details
Apple crash trace (53.44 KB, text/plain)
2019-03-22 10:41 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2018-12-18 11:39:56 UTC
Description:
Just installed LO6132 on macOS 10.14.2 (Mojave latest system update)

Steps to Reproduce:
mdworker is a system process that runs in the background on macOS. It calls inspection code from apps to allow display of file content in the file preview in Finder.

Actual Results:
mdworker keeps crashing and displaying an error message when calling OOoSpotlightImporter

Expected Results:
The OOoSpotlightImporter shouldn't cause mdworker to crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Alex Thurgood 2018-12-18 11:40:46 UTC
Regression because although this problem was present in earlier versions of LO with earlier versions of macOS, the problem has come back with Mojave 10.14
Comment 2 Alex Thurgood 2018-12-18 11:42:50 UTC
Created attachment 147647 [details]
Crash backtrace provided by Apple

Enclosing backtrace provided by Apple
Comment 3 Alex Thurgood 2018-12-18 16:20:13 UTC
More info :

OOoSpotlightImporter is called by the mdimporter/mdworker process and searches through all ODF documents on the system.

In this particular instance, mdworker is barfing on a number of test ODT documents that can be found in my dev tree :

forcepoint-dtor-1.odt (/core/sw/qa/core/data/odt/fail/)

is just one of such files.
Comment 4 Xisco Faulí 2019-01-17 16:36:09 UTC
Hi Alex,
is it another bug related to bug 121778 ?
Comment 5 Alex Thurgood 2019-02-06 12:03:07 UTC
(In reply to Xisco Faulí from comment #4)
> Hi Alex,
> is it another bug related to bug 121778 ?

No, probably not. This problem was reported previously as bug 47689
Comment 6 Alex Thurgood 2019-03-22 10:41:45 UTC
Created attachment 150175 [details]
Apple crash trace

After an update to macOS 10.14.3, mdworker starts crashing yet again when calling the OOoSpotlight plugin on some files
Comment 7 GHDsports 2019-03-23 09:24:56 UTC Comment hidden (spam)
Comment 8 Commit Notification 2019-04-15 06:08:03 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/9f392d0c09bd946e4660ccc2d48ee3ae1367343c%5E%21

tdf#122172 set textContent to nil in OOoContentDataProvider

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Tomaz Vajngerl 2019-04-23 01:18:02 UTC
Some confirmation would be fine. Closing as fixed for now.
Comment 10 Commit Notification 2019-04-24 09:17:24 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/9566be49c249f95d58eaf888fcaa3c48607cad7c%5E%21

tdf#122172 set textContent to nil in OOoContentDataProvider

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 cyberflix app 2019-06-30 20:03:49 UTC Comment hidden (spam)
Comment 12 ghd sports 2019-07-02 17:08:00 UTC Comment hidden (spam)
Comment 13 gomaxtv 2019-07-02 17:15:12 UTC Comment hidden (spam)
Comment 14 Alex Thurgood 2019-09-04 11:00:05 UTC
Indeed, I don't see this anymore in the logs, thanks for fixing !