Download it now!
Bug 61010 - mdimporter is no good for Mountain Lion
Summary: mdimporter is no good for Mountain Lion
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-17 17:18 UTC by Jim White
Modified: 2019-02-06 13:21 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim White 2013-02-17 17:18:56 UTC
On a fresh LO 4.0.0.3 install on a brand new Mountain Lion Mac, the Spotlight importer doesn't work.  

mdworker32[3537]: (Error) Import: BAD IMPORTER ~~~~~~~~~~~~~~~~~~ file://localhost/Applications/LibreOffice.app/Contents/Library/Spotlight/OOoSpotlightImporter.mdimporter/

I'm thinking this is different than  #47689 because I get no crash log (also different version).
Comment 1 Julien Nabet 2013-02-23 19:02:52 UTC
Roman/Alex: could one of you give it a try?
Comment 2 Petri Sirkkala 2013-02-25 21:39:15 UTC
I have similar system.log entries as Jim. Here is what mdworker is reporting for me:

---------------------------------------------------
Feb 25 23:30:28 Petri-iMac.local mdworker32[5569]: Cannot find function pointer MetadataImporterPluginFactory for factory A3FCC88D-B9A6-4364-8B93-92123C8A2D18 in CFBundle/CFPlugIn 0x78e4d770 </Applications/LibreOffice 4.0.0.app/Contents/Library/Spotlight/OOoSpotlightImporter.mdimporter> (bundle, loaded)
Feb 25 23:30:28 Petri-iMac.local mdworker32[5569]: (Error) Import: Could not create instance for plugIn 'file://localhost/Applications/LibreOffice%204.0.0.app/Contents/Library/Spotlight/OOoSpotlightImporter.mdimporter/'
Feb 25 23:30:28 Petri-iMac.local mdworker32[5569]: (Error) Import: BAD IMPORTER ~~~~~~~~~~~~~~~~~~ file://localhost/Applications/LibreOffice%204.0.0.app/Contents/Library/Spotlight/OOoSpotlightImporter.mdimporter/
---------------------------------------------------
Comment 3 Julien Nabet 2013-02-25 22:17:44 UTC
thank you Petri for your feedback. Since you're the second one to have this, put it at NEW.

Thorsten: macos specific, one for you?
Comment 5 Thorsten Behrens (CIB) 2013-02-25 23:21:04 UTC
I think Tor looked into that recently?
Comment 6 Don't use this account, use tml@iki.fi 2013-02-26 06:44:06 UTC
Yep, this should be fixed in 4.0.1.

There were two separate problems:

1) The importer (which is a dynamic library even if its name doesn't end in .dylib) didn't export the symbol MetadataImporterPluginFactory, as seen in the message in comment #2.

2) The code in the importer (which, perhaps sadly, handles only ODF documents) didn't parse the outer ZIP archive structure of ODF documents properly; this was evident only after problem 1 was fixed.
Comment 7 Don't use this account, use tml@iki.fi 2013-02-26 06:44:21 UTC
"should" as in "hopefully is"
Comment 8 Thorsten Behrens (CIB) 2013-02-26 09:34:17 UTC
Then let's state it as such - 4.0.1 rc2 due end of the week for verification, thx Tor for addressing it!
Comment 9 ace_dent 2014-03-18 21:10:04 UTC
Spotlight still not working... Regression?

MacBook Pro 13-inch, Mid 2012 intel.
OS X 10.8.5 (12F45) 'Mountain Lion'.
LibreOffice Version: 4.2.0.4 Clean install.
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Files are not indexed / searchable with Spotlight. Running mdimport manually seems to fail silently. Checking logs reveals:
18/03/2014 20:57:17.756 mdworker[72766]: Error 4, Description: (null), Line: 1, Column: 1
18/03/2014 20:57:17.758 mdworker[72766]: An error occurred parsing the document. (Error 4, Description: (null), Line: 1, Column: 1)
18/03/2014 20:57:17.760 mdworker[72766]: Error 4, Description: (null), Line: 1, Column: 1
18/03/2014 20:57:17.762 mdworker[72766]: An error occurred parsing the document. (Error 4, Description: (null), Line: 1, Column: 1)
18/03/2014 20:57:17.765 mdworker[72766]: Error 4, Description: (null), Line: 1, Column: 1
18/03/2014 20:57:17.766 mdworker[72766]: An error occurred parsing the document. (Error 4, Description: (null), Line: 1, Column: 1)
18/03/2014 20:57:23.948 mdworker[72766]: An error occurred parsing the document. (Error 201, Description: (null), Line: 1, Column: 211)
18/03/2014 20:57:23.948 mdworker[72766]: An error occurred parsing the document. (Error 201, Description: (null), Line: 1, Column: 211)
18/03/2014 20:57:23.948 mdworker[72766]: An error occurred parsing the document. (Error 201, Description: (null), Line: 1, Column: 238)
18/03/2014 20:57:23.948 mdworker[72766]: An error occurred parsing the document. (Error 201, Description: (null), Line: 1, Column: 238)
18/03/2014 20:57:23.948 mdworker[72766]: An error occurred parsing the document. (Error 201, Description: (null), Line: 1, Column: 252)
18/03/2014 20:57:23.948 mdworker[72766]: An error occurred parsing the document. (Error 201, Description: (null), Line: 1, Column: 281)
18/03/2014 20:57:23.948 mdworker[72766]: An error occurred parsing the document. (Error 201, Description: (null), Line: 1, Column: 281)
18/03/2014 20:57:23.948 mdworker[72766]: An error occurred parsing the document. (Error 201, Description: (null), Line: 1, Column: 295)
... and so on...
Comment 10 ace_dent 2014-03-18 21:12:58 UTC
Linked: https://bugs.freedesktop.org/show_bug.cgi?id=38757?
Comment 11 Julien Nabet 2015-12-10 20:38:39 UTC
After one year and a half, any update with last stable LO version 5.0.3?
Indeed, there's now only 64bits LO for MacOs.
Of course, for the test please rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Mac_OS_X)
Comment 12 Alex Thurgood 2015-12-14 16:21:31 UTC
Test on OSX 10.11.2

mdimport -d 4 /Users/alex/Downloads/test\(1\).odb 
(Import.Debug:1319) file:/Users/alex/Downloads/test(1).odb plugin:file:///Volumes/BUILDHD/Shared/LO/core/instdir/LibreOfficeDev.app/Contents/Library/Spotlight/OOoSpotlightImporter.mdimporter/ /Volumes/BUILDHD/Shared/LO/core/instdir/LibreOfficeDev.app/Contents/Library/Spotlight/OOoSpotlightImporter.mdimporter
(Import.Info:845) org.oasis-open.opendocument.database 
(Import.Debug:1598) Attributes for file /Users/alex/Downloads/test(1).odb: {
    ":MD:DeviceId" = 16777220;
    ":MD:kMDExtendedImportDictionary" =     {
    };
    ":MD:kMDItemPath" = "/Users/alex/Downloads/test(1).odb";
    "_kMDItemContentChangeDate" = "2015-12-10 11:45:11 +0000";
    "_kMDItemCreationDate" = "2015-12-10 10:23:10 +0000";
    "_kMDItemCreatorCode" = 0;
    "_kMDItemFileName" = "test(1).odb";
    "_kMDItemFinderFlags" = 0;
    "_kMDItemFinderLabel" = 0;
    "_kMDItemIsExtensionHidden" = 0;
    "_kMDItemOwnerGroupID" = 20;
    "_kMDItemOwnerUserID" = 501;
    "_kMDItemPrescanCandidate" = 1;
    "_kMDItemTypeCode" = 0;
    "com_apple_metadata_modtime" = 471440711;
    kMDItemContentCreationDate = "2015-12-10 10:23:10 +0000";
    kMDItemContentModificationDate = "2015-12-10 11:45:11 +0000";
    kMDItemContentType = "org.oasis-open.opendocument.database";
    kMDItemContentTypeTree =     (
        "org.oasis-open.opendocument.database",
        "public.data",
        "public.item",
        "public.content"
    );
    kMDItemDateAdded = "2015-12-10 10:23:13 +0000";
    kMDItemDisplayName =     {
        "" = "test(1).odb";
    };
    kMDItemKind =     {
        "" = "OpenDocument Database";
    };
    kMDItemLogicalSize = 12204;
    kMDItemPhysicalSize = 12288;
}
2015-12-14 17:18:46.919 mdimport[96089:690637] Imported '/Users/alex/Downloads/test(1).odb' of type 'org.oasis-open.opendocument.database' with plugIn /Volumes/BUILDHD/Shared/LO/core/instdir/LibreOfficeDev.app/Contents/Library/Spotlight/OOoSpotlightImporter.mdimporter.
2015-12-14 17:18:46.920 mdimport[96089:690637] Attributes: {
    ":MD:DeviceId" = 16777220;
    ":MD:kMDExtendedImportDictionary" =     {
    };
    ":MD:kMDItemPath" = "/Users/alex/Downloads/test(1).odb";
    "_kMDItemContentChangeDate" = "2015-12-10 11:45:11 +0000";
    "_kMDItemCreationDate" = "2015-12-10 10:23:10 +0000";
    "_kMDItemCreatorCode" = 0;
    "_kMDItemFileName" = "test(1).odb";
    "_kMDItemFinderFlags" = 0;
    "_kMDItemFinderLabel" = 0;
    "_kMDItemIsExtensionHidden" = 0;
    "_kMDItemOwnerGroupID" = 20;
    "_kMDItemOwnerUserID" = 501;
    "_kMDItemPrescanCandidate" = 1;
    "_kMDItemTypeCode" = 0;
    "com_apple_metadata_modtime" = 471440711;
    kMDItemAlternateNames =     (
        "/Users/alex/Downloads/test(1).odb"
    );
    kMDItemContentCreationDate = "2015-12-10 10:23:10 +0000";
    kMDItemContentModificationDate = "2015-12-10 11:45:11 +0000";
    kMDItemContentType = "org.oasis-open.opendocument.database";
    kMDItemContentTypeTree =     (
        "org.oasis-open.opendocument.database",
        "public.data",
        "public.item",
        "public.content"
    );
    kMDItemDateAdded = "2015-12-10 10:23:13 +0000";
    kMDItemDisplayName =     {
        "" = "test(1).odb";
    };
    kMDItemKind =     {
        "" = "OpenDocument Database";
    };
    kMDItemLogicalSize = 12204;
    kMDItemPhysicalSize = 12288;
}


So, seems to work here, or have I misunderstood something ?
Comment 13 Julien Nabet 2019-02-06 13:21:24 UTC
Alex:pb is in Lion Mountain/10.8. Since min prerequisite for LO is 10.8, it may be still relevant.