Bug 122244 - Installer DMG window on macOS has a misplaced "bin" folder icon
Summary: Installer DMG window on macOS has a misplaced "bin" folder icon
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords: notBibisectable, regression
Depends on:
Blocks: Installer
  Show dependency treegraph
 
Reported: 2018-12-21 10:34 UTC by Andrew Watson
Modified: 2019-11-05 15:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of DMG window (101.49 KB, image/png)
2018-12-21 10:37 UTC, Andrew Watson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Watson 2018-12-21 10:34:40 UTC
Description:
When installing LO 6.2.0.1 RC1 on Mac, double-clicking on the DMG file (LibreOffice_6.2.0.1_MacOS_x86-64.dmg) pops up an installer window which has a misplaced "bin" folder icon on top of the LibreOffice icon.

Steps to Reproduce:
1. Download LibreOffice_6.2.0.1_MacOS_x86-64.dmg via link from https://wiki.documentfoundation.org/QA/BugHuntingSession/6.2.0RC1#How_to_Test_it

2. Double-click on LibreOffice_6.2.0.1_MacOS_x86-64.dmg


Actual Results:
MacOS finder window pops up containing Libreoffice banner at top.

Expected Results:
MacOS window pops up as expected, but has directory icon for "bin" superimposed upon it. See attached screenshot (Screen Shot 2018-12-21 at 10.14.20.png).


Reproducible: Always


User Profile Reset: No



Additional Info:
System Software Overview:

  System Version:	OS X 10.11.6 (15G22010)
  Kernel Version:	Darwin 15.6.0
  Boot Volume:	Macintosh HD
  Boot Mode:	Normal
  Secure Virtual Memory:	Enabled
  System Integrity Protection:	Enabled
  Time since boot:	3 days 6:18


Hardware Overview:

  Model Name:	MacBook Air
  Model Identifier:	MacBookAir7,2
  Processor Name:	Intel Core i7
  Processor Speed:	2.2 GHz
  Number of Processors:	1
  Total Number of Cores:	2
  L2 Cache (per Core):	256 KB
  L3 Cache:	4 MB
  Memory:	8 GB
  Boot ROM Version:	MBA71.0178.B00
  SMC Version (system):	2.27f2
  Serial Number (system):	FVFTK0PTH3QK
  Hardware UUID:	9CABE98A-643F-5C26-A663-7D9AC027C835
Comment 1 Andrew Watson 2018-12-21 10:37:17 UTC
Created attachment 147736 [details]
Screenshot of DMG window

Screenshot "Screen Shot 2018-12-21 at 10.14.20.png" showing misplaced "bin" icon.
Comment 2 Alex Thurgood 2018-12-21 10:44:50 UTC
Confirming.

Also present on all master builds.

The problem has been around for a while now, however, I can't remember exactly back to when (as someone who builds for myself from master on macOS) and makes a DMG of the build.
Comment 3 Alex Thurgood 2018-12-21 10:46:30 UTC
Note that the bin folder is present in the instdir of the buildtree and contains the file

InfoPlist_en-US.zip
Comment 4 Xisco Faulí 2019-01-17 16:37:09 UTC
@Tor, do you have any idea why this is happening ?
Comment 5 Andrew Watson 2019-01-18 08:57:30 UTC
Bug still present in 6.2 RC2:

Version: 6.2.0.2
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; VCL: osx; 
Locale: en-GB (en.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Andrew Watson 2019-02-05 17:02:23 UTC
Bug still present in 6.2 RC3:

Version: 6.2.0.3
Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; VCL: osx; 
Locale: en-GB (en.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Andrew Watson 2019-04-19 16:17:24 UTC
Bug still present in LO 6.2.3:

Version: 6.2.3.2
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; VCL: osx; 
Locale: en-GB (en.UTF-8); UI-Language: en-US
Calc: threaded
Comment 8 Stephan Bergmann 2019-04-24 15:06:42 UTC
(The code that generates the bin folder containing InfoPlist_*.zip in instdir is

> $(eval $(call gb_Package_add_files,infoplist,bin,\
> 	$(foreach lang,en-US $(gb_WITH_LANG),InfoPlist_$(lang).zip) \
> ))

in sysui/Package_infoplist.mk, but which is there ever since 01344a8ca57636ac87108c22f777a02fe6d963d5 "convert sysui to gbuild and add to tail_build" from 2013.)
Comment 9 Commit Notification 2019-04-25 11:28:36 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/7a08bfeabe21193e04b9747a831653efcfc63190%5E%21

tdf#122244 Put InfoPlist.strings files at correct places on macOS

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-04-26 20:43:23 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/5c63768411a57cd23cb8fb2369bce0158bd38d40%5E%21

tdf#122244 Put InfoPlist.strings files at correct places on macOS

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Andrew Watson 2019-05-21 09:48:35 UTC
Confirming that the bug is now fixed in:

Version: 6.3.0.0.alpha1
Build ID: 547edd20e527fb02900f6174973770d26306e2e7
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; VCL: osx; 
Locale: en-US (en.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Xisco Faulí 2019-05-21 09:50:18 UTC
Setting to VERIFIED then