Download it now!
Bug 122275 - LibO 6.2.0 RC1 starts up with a too small window
Summary: LibO 6.2.0 RC1 starts up with a too small window
Status: RESOLVED DUPLICATE of bug 120791
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-12-21 21:50 UTC by sergio.callegari
Modified: 2018-12-27 10:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2018-12-21 21:50:40 UTC
Description:
LibO 6.2.0 RC1 in Linux with the KDE5 VCL on KDE 5 starts up with a too small window (about 1/6 in length or height of the screen estate).

Steps to Reproduce:
1. Start libreoffice from the command line on KDE5

Actual Results:
LibO starts up with a window that is so small that it cannot even show its edit pane.

Expected Results:
LibO should start with a window taking up enough space on the screen to be usable.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: 
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Michael Weghorn 2018-12-22 08:50:12 UTC
Does this happen for you every time or is the window size remembered if you maximize the tiny window, close LibreOffice and start again?

Does it happen with a fresh user profile as well?

For me, it does not happen with a fresh user profile, but it happens when I first start LibreOffice Writer with the 'gtk3' VCL plugin, and then with 'kde5', i.e. running

    SAL_USE_VCLPLUGIN=gtk3 ./instdir/program/soffice --writer
    SAL_USE_VCLPLUGIN=kde5 ./instdir/program/soffice --writer

Fortunately, the window starts up maximized again once I have manually maximized it and closed LibreOffice (and don't start with another VCL plugin in between).

Version: 6.3.0.0.alpha0+
Build ID: 3103f9f9461f6eabb61a70be73862ef4be98010e
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Vera Blagoveschenskaya 2018-12-23 13:47:50 UTC
See also https://bugs.documentfoundation.org/show_bug.cgi?id=120791#c2
Comment 3 Xisco Faulí 2018-12-27 10:17:08 UTC
I guess we can close this a dupe of bug 120791

*** This bug has been marked as a duplicate of bug 120791 ***