Bug Hunting Session
Bug 122307 - Wizards: Dialog for form elements like list box wizard or group box wizard isn't resizable any more
Summary: Wizards: Dialog for form elements like list box wizard or group box wizard is...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.2
Keywords: bibisected, bisected, needsDevEval, regression
Depends on:
Blocks: Base-UX Database-Wizard
  Show dependency treegraph
 
Reported: 2018-12-24 14:48 UTC by Robert Großkopf
Modified: 2019-04-05 18:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2018-12-24 14:48:44 UTC
Have made screenshots for the Base Handbook.
I have tried to resize the wizard dialogs as I have done in older versions of LO, for example LO 5.1.5.2.
Resizing dialogs doesn't work any more. Fixed size leads to the special problem of bug 122305 (Text ends abruptly because there isn't any wordwrap).

All tested with LO 6.1.4.2, OpenSUSE 15, 64bit rpm Linux.

For details see screenshots of
https://bugs.documentfoundation.org/attachment.cgi?id=147801
Comment 1 Xisco Faulí 2018-12-27 10:10:48 UTC
Hi Robert,
Are you sure the dialog was resizable in previous versions?
I can't resize it in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 2 Robert Großkopf 2018-12-27 11:29:45 UTC
(In reply to Xisco Faulí from comment #1)
> Hi Robert,
> Are you sure the dialog was resizable in previous versions?

I have tested it again:

With this version I could resize dialogs:
Version: 5.2.7.2
Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
CPU Threads: 6; OS Version: Linux 4.12; UI Render: default; VCL: gtk2; 
Locale: de-DE (de_DE.UTF-8); Calc: group

I have made screenshots for Base-Handbook with OpenSUSE 15, 64bit rpm, xfce and clearlooks (gtk2). Resizing works for list box wizard, combo box wizard and group box wizard ...

OK, I see the wrong content in the title: "Form-Wizard". The "Form-Wizard" couldn't be resized in any version I have tested ...

Will correct the title.
Comment 3 raal 2019-01-30 17:59:49 UTC
This seems to have begun at the below commit.
Adding Cc: to heiko tietze  ; Could you possibly take a look at this one?
Thanks

5ad64ea6cccad758dae4d7dfb34544774b892484 is the first bad commit
commit 5ad64ea6cccad758dae4d7dfb34544774b892484
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Mon Feb 27 19:10:27 2017 +0100

    source sha:e8147b4b7107cc2fdb68a76deb3d30296a67434d

author	heiko tietze <tietze.heiko@gmail.com>	2017-02-26 11:49:37 +0100
committer	Adolfo Jayme Barrientos <fitojb@ubuntu.com>	2017-02-27 12:43:51 +0000
commit	e8147b4b7107cc2fdb68a76deb3d30296a67434d (patch)
tree	ac2b348e98afc0da496294d5a05c96ce1131881c
parent	9eaa17e6bb35a2cb71ec59c96ea4a39466789667 (diff)
tdf#105299 Dialogs must not be resizable
Patch doesnt solve the issue but makes the wizard dialog HIG compliant
Comment 4 Heiko Tietze 2019-01-30 18:02:14 UTC
Why do you need to resize the dialog? If there is no urgent need, the clean solution is    to fix the word wrap problem.
Comment 5 Robert Großkopf 2019-01-30 19:30:40 UTC
(In reply to Heiko Tietze from comment #4)
> Why do you need to resize the dialog? If there is no urgent need, the clean
> solution is    to fix the word wrap problem.

Have described it in the report. I don't need this dialogues for creating anything with Base. I only make screenshots for Base-Handbook to show, what could be done with Base.

The word wrap-problem is the more important problem. So I can't make screenshots of this dialogues in any version since 5.3.*. I prefer not to show the bugs of LO in a Handbook.
Comment 6 Heiko Tietze 2019-02-15 16:10:35 UTC
Tried to remove the <property name="max_width_chars">82</property> from extensions/uiconfig/sabpilot/ui/optiondbfieldpage.ui and to force a redraw at setDescriptionText() in commonpagesdbp.hxx #110, both with no success. Any idea, Caolan? Wordwrap is still automatic but the text get's ellipsis at the end, also when I request a certain width for the label.
Comment 7 Caolán McNamara 2019-02-17 16:37:11 UTC
https://gerrit.libreoffice.org/#/c/67942/ makes this wrap as wanted I believe
Comment 8 Heiko Tietze 2019-02-17 19:04:42 UTC
(In reply to Caolán McNamara from comment #7)
> https://gerrit.libreoffice.org/#/c/67942/ makes this wrap as wanted I believe

Out of curiosity, why is wordwrap not working in this dialog and you have to calculate both width and height?
Comment 9 Commit Notification 2019-02-17 21:18:46 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/3bb5e0c6dc5f069b8af39cdb669913e286a294fd%5E%21

tdf#122305 tdf#122307 wrap label based on current wizard width

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Heiko Tietze 2019-02-18 00:08:45 UTC
Duplicate of bug 122305
Comment 11 Commit Notification 2019-02-18 01:11:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/a2e9836a7591e5c018cdb7f6d9e35db3a5853d54%5E%21

tdf#122305 tdf#122307 wrap label based on current wizard width

It will be available in 6.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.