Bug Hunting Session
Bug 122398 - UI: Cannot specify min/max in axis scale or axis position. Limited between 0 and 100
Summary: UI: Cannot specify min/max in axis scale or axis position. Limited between 0 ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All All
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.0
Keywords: notBibisectable, regression
: 122401 122528 (view as bug list)
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2019-01-01 07:11 UTC by Kriton Kyrimis
Modified: 2019-02-14 19:38 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet with a chart showing the problem (15.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-01-01 07:11 UTC, Kriton Kyrimis
Details
File with XY chart with date values on x-axis (21.38 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-01-04 19:22 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kriton Kyrimis 2019-01-01 07:11:37 UTC
Created attachment 147914 [details]
Spreadsheet with a chart showing the problem

Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: el-GR (en_US.UTF-8); UI-Language: en-US
Calc: threaded

In a chart that contains an axis with a date datatype, the UI does not allow specifying a minimum or maximum value greater than 09/04/1900 (i.e., April 9, 1900).

E.g., see attached chart.ods. If I uncheck the minimum or maximum value of the X axis, the corresponding input field will show 09/04/1900, and the spinner controls will only allow decreasing that value. If I enter a later date by hand, e.g., 01/01/2019, and hit tab, that date will be changed to 09/04/1900.

This seems to be a UI only issue. If I unpack the ods file, edit the corresponding content.xml file by hand, adjust chart:minimum to an appropriate value (e.g., 43466 for 1/1/2019), and repack, the chart scale appears correct, though LibreOffice still shows 09/04/1900 in the Format Axis dialog, and still does not allow entering higher values. The same goes for charts that had been created with previous versions of LibreOffice.

The problem appears with both the gtk and the kde UI.
Comment 1 Kriton Kyrimis 2019-01-01 07:29:20 UTC
If I set the minimum value of the X axis in chart.ods to 09/04/1900, save, and unpack, I see that chart:minimum has a value of 100 in "Object 2/content.xml". Could it be that there is an incorrect range check for dates, permitting values in the 0-100 range, like percentages, instead of whatever is appropriate for dates?
Comment 2 Xavier Van Wijmeersch 2019-01-01 08:19:50 UTC
confirm with

Version: 6.3.0.0.alpha0+
Build ID: 19d9ac1031a08525ed5a5638ceaf508be870825e
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-12-16_01:24:21
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Happy NewYear to you all
Comment 3 GerardF 2019-01-01 15:06:11 UTC
May be a duplicate of bug 122401
Comment 4 Xavier Van Wijmeersch 2019-01-01 15:06:31 UTC
*** Bug 122401 has been marked as a duplicate of this bug. ***
Comment 5 Alois Klotz 2019-01-01 22:32:33 UTC
custom axis values (minimum, maximum...) are only possible if data value < 100
Comment 6 Laurent BP 2019-01-02 09:03:22 UTC
Negative values are neither possible

Suspected Commit:
https://cgit.freedesktop.org/libreoffice/core/commit/chart2/uiconfig/ui/tp_Scale.ui?id=11300c48d4350c2f6748a1ca04b919cfae338d41

GtkAdjustment should be remove. However, without GTkAdjustment, values are limited between 0 and 0... It needs a deeper rework of UI.

Actual behavior limits values between 0 and 100 for minimum, maximum, major/minor interval (lower is 1) and also position of axis at value.
It impacts not only date, but whatever type of value.

Change summary.
Add regression as keyword
Enhanced severity to major as their no workaround, previous set of min/max scale may be lost.
Change product to Chart
Change Hardware to all
Comment 7 Kriton Kyrimis 2019-01-02 12:07:02 UTC
As far as I can tell, the above commit refers to the GTK+ interface. The problem, however, also exists with the KDE5 and (just checked!) the X11 interface, so there are other places that need to be patched, as well.

Since the problem is common in all three Linux VCLs, it might also exist in the VCLs for the other platforms, as well.
Comment 8 Regina Henschel 2019-01-04 19:22:52 UTC
Created attachment 148042 [details]
File with XY chart with date values on x-axis

Open attached file. Set chart into edit mode. Select x-axis and then Format Selection.
Disable the Automatic for min and max. You cannot change the values at all, neither with direct input nor with up-down arrow buttons.

The last version on my pc, where it is OK, is Version: 6.2.0.0.alpha0+ (x64)
Build ID: 6baca63b44bf7f75a522b1adc4b4bbce502aec3b
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-20_01:35:41
Locale: en-US (en_US); Calc: threaded

The next versions I have got, crashes, when clicking on Format Selection.

Then version Version: 6.2.0.1 (x64)
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
does no longer crash, but has the buggy dialog.

The error exists too in version 6.3

I'm not sure, whether this fits exactly to the other cases. If not, tell me and I write a new report.
Comment 9 Regina Henschel 2019-01-07 23:16:36 UTC
*** Bug 122528 has been marked as a duplicate of this bug. ***
Comment 10 Xisco Faulí 2019-01-07 23:38:55 UTC
It can't be bisected due to the crash from bug 121246.

@Caolán, Could it be possible it was introduced by 8947c9b1d8cd407131fdfb6fc3c77c8532e9d2a0 ??
Comment 11 Libomark 2019-01-08 10:53:22 UTC
I would not consider using a 6.2 release without this being fixed.  I was hoping to move to 6.2 once it goes live in order to fix other issues and gain the added functionality.  For me it is critical.
Comment 12 Commit Notification 2019-01-10 16:31:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/34973d2c957606e0b793d007ad709160e7797ed7%5E%21

Resolves: tdf#122398 max/min limits too small for scale FormattedSpinButtons

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Caolán McNamara 2019-01-10 16:32:51 UTC
backport to 6-2 in gerrit, fixed in master
Comment 14 Xisco Faulí 2019-01-11 11:04:25 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: c164dbaff63d67f5e89d133c272412aaf4c5c158
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this!!
Comment 15 Commit Notification 2019-01-11 11:07:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d8f5ff4d1580d486df7ad1df380df59792439575%5E%21

Resolves: tdf#122398 max/min limits too small for scale FormattedSpinButtons

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Kriton Kyrimis 2019-01-11 11:22:38 UTC
> It will be available in 6.2.1.

How about 6.2.0? There should still be enough time before RC3 is released.
Comment 17 Xisco Faulí 2019-01-11 11:23:47 UTC
(In reply to Kriton Kyrimis from comment #16)
> > It will be available in 6.2.1.
> 
> How about 6.2.0? There should still be enough time before RC3 is released.

https://gerrit.libreoffice.org/#/c/66126/
Comment 18 Kriton Kyrimis 2019-01-11 11:30:40 UTC
> https://gerrit.libreoffice.org/#/c/66126/

Great!
Comment 19 Jean-Baptiste Faure 2019-01-11 12:03:38 UTC
Verified fixed in LO 6.2.1.0.0+

Thank you very much. :-)

Best regards. JBF
Comment 20 Commit Notification 2019-01-21 17:16:20 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-0":

https://git.libreoffice.org/core/+/6b7b09eb0742c9d32ad78c0e94fa406dfbffeab3%5E%21

Resolves: tdf#122398 max/min limits too small for scale FormattedSpinButtons

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2019-02-14 19:38:33 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/45dffbec473f6f4cba7663a458c3d076095b97fd%5E%21

uitest for bug tdf#122398

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.