Bug 121246 - Crash clicking on 'row' of a chart (with missing chart bars)
Summary: Crash clicking on 'row' of a chart (with missing chart bars)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0
Keywords: bibisected, bisected, haveBacktrace, regression
: 121454 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-07 14:05 UTC by Telesto
Modified: 2018-11-19 08:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (8.91 KB, text/plain)
2018-11-10 21:12 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-11-07 14:05:25 UTC
Description:
Crash clicking on 'row' of a chart (with missing chart bars)

Steps to Reproduce:
1. Open Writer
2. Insert a chart (chart sticks are missing on MacOS..)
3. Double click on the text "Row 1" -. Crash

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha1+
Build ID: 317f5f2323b8ff7948c4812faaeb0c2a3b907ce8
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-11-07_00:12:59
Locale: nl-NL (nl_NL.UTF-8); Calc: threaded
Comment 1 Xisco Faulí 2018-11-07 15:00:53 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8947c9b1d8cd407131fdfb6fc3c77c8532e9d2a0

author	Caolán McNamara <caolanm@redhat.com>	2018-10-18 13:00:41 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-10-20 13:52:34 +0200
commit	8947c9b1d8cd407131fdfb6fc3c77c8532e9d2a0 (patch)
tree	f47becc099d139ae601fc41d9e8f49f24672f0e0
parent	b361413eef7e46f340d921708faca9986c63c9f8 (diff)
weld SchAttribTabDlg

Bisected with: bibisect-linux64-6.2

Adding Cc: to Caolán McNamara
Comment 2 Julien Nabet 2018-11-10 21:12:35 UTC
Created attachment 146530 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 3 Julien Nabet 2018-11-11 14:10:33 UTC
*** Bug 121341 has been marked as a duplicate of this bug. ***
Comment 4 Caolán McNamara 2018-11-14 10:04:53 UTC
missed unwelded tabpages are the problem here
Comment 5 Caolán McNamara 2018-11-16 09:50:54 UTC
*** Bug 121454 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2018-11-16 13:52:54 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/11300c48d4350c2f6748a1ca04b919cfae338d41%5E%21

Resolves: tdf#121246 crash in chart dialogs

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 BogdanB 2018-11-19 08:57:43 UTC
No crash on

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded