Bug 121341 - choosing insert trend line causes crash
Summary: choosing insert trend line causes crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0
Keywords: bibisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2018-11-10 21:45 UTC by Cathy Crumbley
Modified: 2018-11-15 20:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Inserting trend line causes crash (19.01 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-11-10 21:45 UTC, Cathy Crumbley
Details
bt with debug symbols (11.10 KB, text/plain)
2018-11-11 14:08 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cathy Crumbley 2018-11-10 21:45:42 UTC
Created attachment 146532 [details]
Inserting trend line causes crash

Trying to Insert  a trend line (after selecting data in the chart) causes Calc to crash. What I tried:

opening in safe mode
cutting and pasting data into new file
starting over with completely new data and file
restoring from backup (not sure how it is worded --- the first choice given when trying to open a program that just crashed)

example file attached

crash report:
http://crashreport.libreoffice.org/stats/crash_details/c5f5d81f-4c57-40e1-a12c-a6688e29b28a

I don't know what more information could be useful. Please bear with me.
Comment 1 Drew Jensen 2018-11-10 22:54:14 UTC
Confirmed with Ubuntu 18.04 and LO 6.2.1Alpha1
Also checked with 6.1.3.2 and that functioned as expected.

Marked as regresion and bibisect request. Will do so after updating the local bibisect repository.
Comment 2 Drew Jensen 2018-11-11 00:55:59 UTC
Bibisect reports that the anomaly arrived with commit:
8947c9b1d8cd407131fdfb6fc3c77c8532e9d2a0

author	Caolán McNamara <caolanm@redhat.com>	2018-10-18 13:00:41 +0100

Titled: weld SchAttribTabDlg
Comment 3 Drew Jensen 2018-11-11 01:00:30 UTC
oops saved before I was done updateing

The commit effected files:
chart2/source/controller/dialogs/dlg_ObjectProperties.cxx
chart2/source/controller/inc/dlg_ObjectProperties.hxx
chart2/source/controller/main/ChartController_Insert.cxx
chart2/source/controller/main/ChartController_Properties.cxx
chart2/uiconfig/ui/attributedialog.ui
include/sfx2/tabdlg.hxx
include/vcl/weld.hxx
sd/uiconfig/simpress/ui/templatedialog.ui
sfx2/source/dialog/tabdlg.cxx
vcl/source/app/salvtables.cxx
vcl/unx/gtk3/gtk3gtkinst.cxx 

Tested with both GTK2 and GTK3, when the crash manifested, it made not difference in behavior. 

Added developer to CC.
Comment 4 Julien Nabet 2018-11-11 14:08:29 UTC
Created attachment 146539 [details]
bt with debug symbols
Comment 5 Julien Nabet 2018-11-11 14:10:33 UTC
Considering bt, it's a dup of tdf#121246

*** This bug has been marked as a duplicate of bug 121246 ***
Comment 6 Xisco Faulí 2018-11-15 12:19:34 UTC
Changing it to ASSIGNED according to https://gerrit.libreoffice.org/#/c/63387/
Comment 7 Commit Notification 2018-11-15 17:46:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/39aa91cfb4620a650ceba01076a1c0aa2fbfdadf%5E%21

Resolves: tdf#121341 weld TrendlineTabPage

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2018-11-15 17:47:49 UTC
this subpart should now be fixed, more to do though
Comment 9 Cathy Crumbley 2018-11-15 19:44:29 UTC
The same problem happens when selecting X axis, Y axis, or All axis. Selecting any of them causes the program to crash. Is that related to what you are working on? I am asking because you say that there is more to do. 

If these other problems are related, should I still file a separate bug report? 

If I should file a bug report, should there be separate reports or can they be combined into one?
Comment 10 Cathy Crumbley 2018-11-15 19:46:34 UTC
To be clear, I am asking if there should be separate reports for X axis, Y axis, and All axis.
Comment 11 Caolán McNamara 2018-11-15 20:57:24 UTC
no, no need to file anything until bug 121246 is resolved, and then only if there are remaining crashes